helpf.pro
Регистрация

v8: Переменная булево

Ermak
17.11.2011 12:31Прочитано: 1439
Такая проблема!
В документ добавил булевскую переменную Ограничение и прописал к ней код

Код 1C v 8.х
 Процедура ОграничениеПриИзменении(Элемент)

Если ЭлементыФормы.Ограничение.Значение = Истина
И ПараметрыСеанса.ТекущийПользователь.Наименование = "Петров" Тогда
ЭлементыФормы.Товары.Колонки.СчетПоставщика.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.ТоварнаяНакладная.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.ТребованиеНакладная.Доступность = Ложь;
КонецЕсли;

КонецПроцедуры


Смысл мой такой: если Ограничение стоит истина тогда не доступны колонки СчетПоставщика, ТоварнаяНакладная, ТребованиеНакладная, но почему то не работает!
Что то не так делаю?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
17.11.2011 13:01Ответ № 1
Код 1C v 8.х
 Если Ограничение И ПараметрыСеанса.ТекущийПользователь.Наименование = "Петров" Тогда   
Ermak
17.11.2011 13:53Ответ № 2
(1) E_Migachev, Работает, но когда проводишь то снова становиться активна. Как сделать чтобы после проведения была не активна?
Изменено 17.11.11 15:59:56
E_Migachev
18.11.2011 10:28Ответ № 3
(2) Ermak, хм.. покажи весь код при открытии
Ermak
18.11.2011 11:08Ответ № 4
Вот код стоит при открытии

Код 1C v 8.х
 Если ЭтотОбъект.Проведен
И ПараметрыСеанса.ТекущийПользователь.Наименование = "Петров" Тогда
ЭлементыФормы.ПолеВвода1.Доступность = Ложь;
ЭлементыФормы.Номер.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.НомерСтроки.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Номер.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Единица.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Количество.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Цена.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Стоимость.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Номенклатура.Доступность = Ложь;


как то надо изменить не пойму
E_Migachev
18.11.2011 12:43Ответ № 5
(4) Ermak, тут все правильно, где-то еще что-то мешает
Ermak
18.11.2011 15:31Ответ № 6
Правильно это да, но когда я ставлю галочку в Ограничение тогда не могу редактировать, работает это услович

Код 1C v 8.х
 ЭлементыФормы.Товары.Колонки.СчетПоставщика.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.ТоварнаяНакладная.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.ТребованиеНакладная.Доступность = Ложь;


потом перепровожу, потом заново открываю документ и работает это условие

Код 1C v 8.х
 
Если ЭтотОбъект.Проведен
И ПараметрыСеанса.ТекущийПользователь.Наименование = "Петров" Тогда
ЭлементыФормы.ПолеВвода1.Доступность = Ложь;
ЭлементыФормы.Номер.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.НомерСтроки.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Номер.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Единица.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Количество.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Цена.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Стоимость.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.Номенклатура.Доступность = Ложь;


тут видно что редактировать СчетПоставщика, ТоварнаяНакладная, ТребованиеНакладная можно.
Вот как сделать что сохранялось условие когда я ставлю галочку?
McCoy
18.11.2011 16:46Ответ № 7
Код 1C v 8.х
 
Процедура УстановитьДоступностьЭлементовФормы()

Если ЭлементыФормы.Ограничение.Значение = Истина
И ПараметрыСеанса.ТекущийПользователь.Наименование = "Петров" Тогда
ЭлементыФормы.Товары.Колонки.СчетПоставщика.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.ТоварнаяНакладная.Доступность = Ложь;
ЭлементыФормы.Товары.Колонки.ТребованиеНакладная.Доступность = Ложь;
КонецЕсли;

КонецПроцедуры

Процедура ПриОткрытии()
Если Проведен Тогда
УстановитьДоступностьЭлементовФормы()
КонецЕсли;
КонецПроцедуры
Ermak
18.11.2011 17:34Ответ № 8
Спасибо все работает!
Ermak
18.11.2011 17:34Ответ № 9
Вопрос закрыт!
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.