helpf.pro
Регистрация

v8.2 УП: Булево

Rustavelli
25.11.2011 10:25Прочитано: 2250
На 8.2 Булево при изменении не работает?
Код 1C v 8.2 УП
 
Если Элементы.Мд = Истина Тогда
Элементы.Получатель.Видимость = Истина;
Иначе
Элементы.Получатель.Видимость = Ложь;
КонецЕсли;


Форма вообще никак не реагирует..
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
25.11.2011 10:56Ответ № 1
(0) Rustavelli,
Код 1C v 8.2 УП
 Элементы.Получатель.Видимость=Элементы.Мд;   
Rustavelli
25.11.2011 11:00Ответ № 2
Спасибо! Тока не получилось, ругается на несоответствие типов..
Изменено 25.11.11 11:04:55
DJ_Serega
25.11.2011 11:09Ответ № 3
У меня нет УП, но на 81 я бы писал так:
Код 1C v 8.х
 Если ЭлементыФормы.Мда.Значение Тогда
ЭлементыФормы.Получатель.Видимость = ЭлементыФормы.Мда.Значение;
КонецЕсли;

Ну или наоборот:
Код 1C v 8.х
 Если ЭлементыФормы.Мда.Значение Тогда
ЭлементыФормы.Получатель.Видимость = НЕ ЭлементыФормы.Мда.Значение;
КонецЕсли;

Изменено 25.11.11 11:09:39
Rustavelli
25.11.2011 11:23Ответ № 4
На 8.1 этот код прошел бы, но почему то на 8.2 не работает и ругается ((
E_Migachev
25.11.2011 11:38Ответ № 5
а если просто написать
Код 1C v 8.2 УП
 ЭлементыФормы.Получатель.Видимость = ЭлементыФормы.Мда.Значение;   

на что ругается?
Rustavelli
25.11.2011 13:31Ответ № 6
на код:
Код 1C v 8.2 УП
 ЭлементыФормы.Получатель.Видимость = ЭлементыФормы.Мда.Значение;   

выдает ошибку поле объекта не обнаружено (Значение),


Код 1C v 8.2 УП
 Элементы.Получатель.Видимость=Элементы.Мд;   

ругается "несоответствие типов", хотя все правильно вроде..
E_Migachev
25.11.2011 14:17Ответ № 7
(6) Rustavelli, а
Код 1C v 8.2 УП
 Элементы.Получатель.Видимость=объект.Мд;   
?
Rustavelli
25.11.2011 15:09Ответ № 8
Спасибо огромное, теперь работает!
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.