helpf.pro
Регистрация

v8: Вывод на печать

Bell
02.12.2011 12:04Прочитано: 1308
Здравствуйте
Вопрос №1
Подскажите как сделать итог по страницам в документе (печатной форме)
Выдает ошибку как преобразовать грамотно если есть какой нибудь шаблон более правильный
{Документ.ТМЦ_Отгрузка.МодульОбъекта(39)}: Преобразование значения к типу Число не может быть выполнено
ПоЛистуКоличество=ПоЛистуКоличество+Количество;
Код 1C v 8.х
 Процедура ТН()  Экспорт

ПоДокументуКоличество = 0; // Итог по документу
ПоЛистуКоличество = 0; // Итог по листу

// Количество строк на странице
СтрокНаЛисте = 30;
Стр = 0;
НомерЛиста = 1; // Первый номер листа


Таб = Новый ТабличныйДокумент;
Макет = ПолучитьОбщийМакет("ТН");
// Секция номерация станиц
НумерацияСтраниц = Макет.ПолучитьОбласть("НумерацияСтраниц");
НумерацияСтраниц.Параметры.Заполнить(ЭтотОбъект);
// Данные для ...
НумерацияСтраниц.Параметры.НомерЛиста = НомерЛиста;
Таб.Вывести(НумерацияСтраниц);
// Секция шапка
Шапка = Макет.ПолучитьОбласть(" Шапка");
Шапка.Параметры.Заполнить( Шапка);
// Данные для ...
Таб.Вывести( Шапка);


// Разворот ТЧ
Строка = Макет.ПолучитьОбласть("Строка");
Для Каждого СтрокаТЧ Из Товары Цикл

Строка.Параметры.Заполнить(СтрокаТЧ);
// Данные для ...
Строка.Параметры.НС = СтрокаТЧ.НомерСтроки;
Строка.Параметры.ТМЦ = СтрокаТЧ.ТМЦ;
Строка.Параметры.ЕдИзм = СтрокаТЧ.ТМЦ.ЕдиницаИзмерения;
Строка.Параметры.Количество = СтрокаТЧ.Количество;


// Здесь ошибка ????
// Количество=Количество;
//ПоЛистуКоличество=ПоЛистуКоличество+Количество;
//ПоДокументуКоличество=ПоДокументуКоличество+Количество;


Если Стр>СтрокНаЛисте Тогда
// Секция итог по странице ????????????????????
ИтогПоСтранице = Макет.ПолучитьОбласть("ИтогПоСтранице");
ИтогПоСтранице.Параметры.Заполнить(ИтогПоСтранице);
// Данные для ...
Таб.Вывести(ИтогПоСтранице);

Стр=0;
Таб.ВывестиГоризонтальныйРазделительСтраниц(); // отделяем страницы после необходимого кол. строк (30)

ПоЛистуКоличество=0;
НомерЛиста=НомерЛиста+1;
// Секция нумерация страниц
НумерацияСтраниц = Макет.ПолучитьОбласть("НумерацияСтраниц");
НумерацияСтраниц.Параметры.Заполнить(ЭтотОбъект);
// Данные для ...
НумерацияСтраниц.Параметры.НомерЛиста = НомерЛиста;
Таб.Вывести(НумерацияСтраниц);
// Секция Шапка
Таб.Вывести( Шапка);
КонецЕсли;

Таб.Вывести(Строка);

Стр=Стр+1;
КонецЦикла;
//Секция итог по страцице
ИтогПоСтранице = Макет.ПолучитьОбласть("ИтогПоСтранице");
ИтогПоСтранице.Параметры.Заполнить(ИтогПоСтранице);
// Данные для ...
Таб.Вывести(ИтогПоСтранице);
// Секция итог по документу
ИтогПоДокументу = Макет.ПолучитьОбласть("ИтогПоДокументу");
ИтогПоДокументу.Параметры.Заполнить(ИтогПоДокументу);
// Данные для ...
Таб.Вывести(ИтогПоДокументу);


Таб.Показать();

КонецПроцедуры

Вопрос №2
Есть ли в 8.2 нумерация страниц, а то не нашел в колонтитулах(или может по другому делается)
Изменено 02.12.11 12:04:52
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
02.12.2011 14:59Ответ № 1
Код 1C v 8.х
 ПоЛистуКоличество=ПоЛистуКоличество+СтрокаТЧ.Количество;   
Bell
02.12.2011 19:32Ответ № 2
Вопрос закрыт!
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.