helpf.pro
Регистрация

v7: График динамики продаж

Striker-11
12.12.2011 00:12Прочитано: 1076
Нужно сделать график зависимости кол-во проданного от месяца
Создал процедуру по подсчёту кол-ва проданного в каждый месяц:

Код 1C v 7.x
 Процедура График() 

ст1=0; ст2=0; ст3=0; ст4=0; ст5=0;ст6=0; ст7=0; ст8=0; ст9=0; ст10=0; ст11=0; ст12=0;

Спр = СоздатьОбъект("Справочник.Дома");

Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ВывестиСекцию("Шапка");

Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
Спр.ВыбратьЭлементы();

Пока Спр.ПолучитьЭлемент() = 1 Цикл

Если ДатаМесяц(Спр.ДатаЗаклДог) = 1 тогда

ст1=ст1+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 2 тогда
ст2=ст2+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 3 тогда
ст3=ст3+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 4 тогда
ст4=ст4+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 5 тогда
ст5=ст5+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 6 тогда
ст6=ст6+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 7 тогда
ст7=ст7+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 8 тогда
ст8=ст8+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 9 тогда
ст9=ст9+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 10 тогда
ст10=ст10+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 11 тогда
ст11=ст11+1;
ИначеЕсли ДатаМесяц(Спр.ДатаЗаклДог) = 12 тогда
ст12=ст12+1;

КонецЕсли;

КонецЦикла;

Таб.ВывестиСекцию("Данные");
Таб.ВывестиСекцию("Диаграмма");
Таб.Показать("Печать Дома","");

КонецПроцедуры


А так же процедуру отчёта с графиком:

Код 1C v 7.x
 Процедура Диаграмма(Диаграмма) 
Спр = СоздатьОбъект("Справочник.Дома");
Таблица = СоздатьОбъект("Таблица");
Таблица.ИсходнаяТаблица("Таблица");
Диаграмма.Обновление(0);
Серия = 1;
Точка = 1;
Диаграмма.КоличествоТочек(12);
Диаграмма.УстановитьЗначение(1,1,2);
Диаграмма.УстановитьЗначение(2,1,1);
Диаграмма.УстановитьЗначение(3,1,2);
Диаграмма.УстановитьЗначение(4,1,2);
Диаграмма.УстановитьЗначение(5,1,3);
Диаграмма.УстановитьЗначение(6,1,3);
Диаграмма.УстановитьЗначение(7,1,4);
Диаграмма.УстановитьЗначение(8,1,5);
Диаграмма.УстановитьЗначение(9,1,1);
Диаграмма.УстановитьЗначение(10,1,1);
Диаграмма.УстановитьЗначение(11,1,2);
Диаграмма.УстановитьЗначение(12,1,2);
Диаграмма.Обновление(1);
КонецПроцедуры


Вопрос в том, как значения ст1, ст2... из первой процедуры использовать в качестве значений точек графика?
Yandex
Возможно, вас также заинтересует
Реклама на портале
Striker-11
12.12.2011 00:43Ответ № 1
Вопрос закрыт!
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.