helpf.pro
Регистрация

v7: Форма списка

Striker-11
30.12.2011 13:59Прочитано: 1125
Один и тот же отчёт формируется почему-то по-разному... Когда группа в свернутом состоянии в отчёт отбираются лишние данные, а когда в развернутом - отчёт формируется правильно...
В чём может быть проблема?
Yandex
Возможно, вас также заинтересует
Реклама на портале
ab
30.12.2011 18:01Ответ № 1
Можно более подробное описание что не так...
а то в версии 7.7. сложно представить себе свёрнутые и развёрнутые группы
Striker-11
31.12.2011 15:51Ответ № 2
title
и
title
Striker-11
31.12.2011 16:06Ответ № 3
На первом рис. группа развернута и в данном случае отчёт формируется нормально...
А вот во втором случае группы свёрнуты, в этом случае в отчёт входит не та информация...
E_Migachev
10.01.2012 11:00Ответ № 4
(3) Striker-11, покажите код отчета...
Striker-11
10.01.2012 14:17Ответ № 5
Код 1C v 7.x
 Процедура Должники()



Спр = СоздатьОбъект("Справочник.Дома");


Таб = СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("Должники");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Таб.ВывестиСекцию("Столбцы");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Спр.ВыбратьЭлементы();


Пока Спр.ПолучитьЭлемент() = 1 Цикл

ОбщСуммаЯнв = Спр.СуммаЯнв1+Спр.СуммаЯнв2+Спр.СуммаЯнв3+Спр.СуммаЯнв4;
ОбщСуммаФев = Спр.СуммаФев1+Спр.СуммаФев2+Спр.СуммаФев3+Спр.СуммаФев4;
ОбщСуммаМарт = Спр.СуммаМарт1+Спр.СуммаМарт2+Спр.СуммаМарт3+Спр.СуммаМарт4;
ОбщСуммаАпр = Спр.СуммаАпр1+Спр.СуммаАпр2+Спр.СуммаАпр3+Спр.СуммаАпр4;
ОбщСуммаМай = Спр.СуммаМай1+Спр.СуммаМай2+Спр.СуммаМай3+Спр.СуммаМай4;
ОбщСуммаИюнь = Спр.СуммаИюнь1+Спр.СуммаИюнь2+Спр.СуммаИюнь3+Спр.СуммаИюнь4;
ОбщСуммаИюль = Спр.СуммаИюль1+Спр.СуммаИюль2+Спр.СуммаИюль3+Спр.СуммаИюль4;
ОбщСуммаАвг = Спр.СуммаАвг1+Спр.СуммаАвг2+Спр.СуммаАвг3+Спр.СуммаАвг4;
ОбщСуммаСент = Спр.СуммаСент1+Спр.СуммаСент2+Спр.СуммаСент3+Спр.СуммаСент4;
ОбщСуммаОкт = Спр.СуммаОкт1+Спр.СуммаОкт2+Спр.СуммаОкт3+Спр.СуммаОкт4;
ОбщСуммаНоябрь = Спр.СуммаНоябрь1+Спр.СуммаНоябрь2+Спр.СуммаНоябрь3+Спр.СуммаНоябрь4;
ОбщСуммаДек = Спр.СуммаДек1+Спр.СуммаДек2+Спр.СуммаДек3+Спр.СуммаДек4;
Об=ОбщСуммаЯнв+ОбщСуммаФев+ ОбщСуммаМарт+ОбщСуммаАпр+ОбщСуммаМай+ОбщСуммаИюнь+ОбщСуммаИюль+ОбщСуммаАвг+ОбщСуммаСент+ОбщСуммаОкт+ОбщСуммаНоябрь+ОбщСуммаДек;
Долг=Спр.СуммаКв-Об;
плСуммаЯнв=Спр.плСуммаЯнв1+Спр.плСуммаЯнв2+Спр.плСуммаЯнв3+Спр.плСуммаЯнв4;
плСуммаФев=Спр.плСуммаФев1+Спр.плСуммаФев2+Спр.плСуммаФев3+Спр.плСуммаФев4;
плСуммаМарт=Спр.плСуммаМарт1+Спр.плСуммаМарт2+Спр.плСуммаМарт3+Спр.плСуммаМарт4;
плСуммаАпр=Спр.плСуммаАпр1+Спр.плСуммаАпр2+Спр.плСуммаАпр3+Спр.плСуммаАпр4;
плСуммаМай=Спр.плСуммаМай1+Спр.плСуммаМай2+Спр.плСуммаМай3+Спр.плСуммаМай4;
плСуммаИюнь=Спр.плСуммаИюнь1+Спр.плСуммаИюнь2+Спр.плСуммаИюнь3+Спр.плСуммаИюнь4;
плСуммаИюль=Спр.плСуммаИюль1+Спр.плСуммаИюль2+Спр.плСуммаИюль3+Спр.плСуммаИюль4;
плСуммаАвг=Спр.плСуммаАвг1+Спр.плСуммаАвг2+Спр.плСуммаАвг3+Спр.плСуммаАвг4;
плСуммаСент=Спр.плСуммаСент1+Спр.плСуммаСент2+Спр.плСуммаСент3+Спр.плСуммаСент4;
плСуммаОкт=Спр.плСуммаОкт1+Спр.плСуммаОкт2+Спр.плСуммаОкт3+Спр.плСуммаОкт4;
плСуммаНоябрь=Спр.плСуммаНоябрь1+Спр.плСуммаНоябрь2+Спр.плСуммаНоябрь3+Спр.плСуммаНоябрь4;
плСуммаДек=Спр.плСуммаДек1+Спр.плСуммаДек2+Спр.плСуммаДек3+Спр.плСуммаДек4;

Если (ДатаМесяц(ТекущаяДата())=1) Тогда
ПланТек=плСуммаЯнв;
ФактТек=ОбщСуммаЯнв;
ПланСл=плСуммаФев;
ххх=Спр.СуммаКв-Об-плСуммаЯнв-плСуммаФев-плСуммаМарт-плСуммаАпр;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=2) Тогда
ПланТек=плСуммаФев;
ФактТек=ОбщСуммаФев;
ПланСл=плСуммаМарт;
ххх=Спр.СуммаКв-Об-плСуммаФев-плСуммаМарт-плСуммаАпр-плСуммаМай;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=3) Тогда
ПланТек=плСуммаМарт;
ФактТек=ОбщСуммаМарт;
ПланСл=плСуммаАпр;
ххх=Спр.СуммаКв-Об-плСуммаМарт-плСуммаАпр-плСуммаМай-плСуммаИюнь-плСуммаИюль;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=4) Тогда
ПланТек=плСуммаАпр;
ФактТек=ОбщСуммаАпр;
ПланСл=плСуммаМай;
ххх=Спр.СуммаКв-Об-плСуммаАпр-плСуммаМай-плСуммаИюнь-плСуммаИюль-плСуммаАвг;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=5) Тогда
ПланТек=плСуммаМай;
ФактТек=ОбщСуммаМай;
ПланСл=плСуммаИюнь;
ххх=Спр.СуммаКв-Об-плСуммаМай-плСуммаИюнь-плСуммаИюль-плСуммаАвг-плСуммаСент;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=6) Тогда
ПланТек=плСуммаИюнь;
ФактТек=ОбщСуммаИюнь;
ПланСл=плСуммаИюль;
ххх=Спр.СуммаКв-Об-плСуммаИюнь-плСуммаИюль-плСуммаАвг-плСуммаСент-плСуммаОкт;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=7) Тогда
ПланТек=плСуммаИюль;
ФактТек=ОбщСуммаИюль;
ПланСл=плСуммаАвг;
ххх=Спр.СуммаКв-Об-плСуммаИюль-плСуммаАвг-плСуммаСент-плСуммаОкт-плСуммаНоябрь;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=8) Тогда
ПланТек=плСуммаАвг;
ФактТек=ОбщСуммаАвг;
ПланСл=плСуммаСент;
ххх=Спр.СуммаКв-Об-плСуммаАвг-плСуммаСент-плСуммаОкт-плСуммаНоябрь-плСуммаДек;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=9) Тогда
ПланТек=плСуммаСент;
ФактТек=ОбщСуммаСент;
ПланСл=плСуммаОкт;
ххх=Спр.СуммаКв-Об-плСуммаСент-плСуммаОкт-плСуммаНоябрь-плСуммаДек-плСуммаЯнв;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=10) Тогда
ПланТек=плСуммаОкт;
ФактТек=ОбщСуммаОкт;
ПланСл=плСуммаНоябрь;
ххх=Спр.СуммаКв-Об-плСуммаОкт-плСуммаНоябрь-плСуммаДек-плСуммаЯнв;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=11) Тогда
ПланТек=плСуммаНоябрь;
ФактТек=ОбщСуммаНоябрь;
ПланСл=плСуммаДек;
ххх=Спр.СуммаКв-Об-плСуммаНоябрь-плСуммаДек-плСуммаЯнв-плСуммаФев;
ИначеЕсли (ДатаМесяц(ТекущаяДата())=12) Тогда
ПланТек=плСуммаДек;
ФактТек=ОбщСуммаДек;
ПланСл=плСуммаЯнв;
ххх=Спр.СуммаКв-Об-плСуммаДек-плСуммаЯнв-плСуммаФев-плСуммаМарт;

КонецЕсли;
Если Спр.ЭтоГруппа() = 1 Тогда
Таб.ВывестиСекцию("Группа");
ИначеЕсли (Долг>0) Тогда
Таб.ВывестиСекцию("Данные");




КонецЕсли;
КонецЦикла;

// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.ВывестиСекцию("Подвал");
Таб.Показать("Должники", "");

КонецПроцедуры
E_Migachev
10.01.2012 14:36Ответ № 6
сделай
Код 1C v 7.x
 Спр.ВыбратьЭлементы(1); 
Striker-11
10.01.2012 14:44Ответ № 7
ничего не изменилось(
E_Migachev
10.01.2012 15:47Ответ № 8
(7) Striker-11, вообщем на свернуто - развернуто ни как не реагирует, выше указанным кодом ты установил что - нужно выбирать справочник по иерархии и так должно все работать
Striker-11
10.01.2012 15:55Ответ № 9
Это я понял... В свёрнутом виде в отчёт входит по одному "левому" значению в каждой группе... Может это глюк? Возможно ли сделать так, чтобы при формировании отчёта группа "разворачивалась"?
E_Migachev
10.01.2012 16:25Ответ № 10
(9) Striker-11, судя по коду - выборка идет по группам и их элементам
ad82117
10.01.2012 16:30Ответ № 11
об'ясните, пожалуйста, что это за рисунки? и как Вы формируете свою печатную форму? откуда? из обработки? из формы списка справочника?
ad82117
10.01.2012 16:42Ответ № 12
пожалуйста, выложите весь скрин справочника
Striker-11
10.01.2012 18:32Ответ № 13
И меется справочник:title
С него я формирую отчёт по коду, указанному выше... Если группа в развернутом виде-отчёт правильный, но когда группы (Дом №) свернуты-в отчёт подбираются лишние данные...
ad82117
11.01.2012 09:41Ответ № 14
вот Вы написали в коде
Спр = СоздатьОбъект("Справочник.Дома");
Спр.ВыбратьЭлементы();
это значит, что идёт перебор ВСЕГО (элементы и группы) справочника "дома".
я так понимаю -
1. нужно, чтобы отчёт формировался по текущей выбранной строке справочника?
сейчас 3 группы ("1","3,","4")
Курсор стоит, например, на "3" и отчёт должен формироваться только по "3" в виде иерархии, т.е. с подчиненными элементами?
или
2. отчёт должен формироваться по всем группам в виде иерархии - в независимости от того, где стоит курсор, т.е. как идёт структура справочника, так она в отчёт и выводится?
Striker-11
11.01.2012 10:43Ответ № 15
Скорее 2-е. В отчёт выводятся все данные справочника удовлетворяющие условию:
Код 1C v 7.x
 Если Спр.ЭтоГруппа() = 1 Тогда
Таб.ВывестиСекцию("Группа");
ИначеЕсли (Долг>0) Тогда
Таб.ВывестиСекцию("Данные");
КонеццЕсли;
ad82117
11.01.2012 11:00Ответ № 16
однако ситуация такая, что если одна из групп раскрыта - данные в печатной форме не такие, как при всех свернутых группах? я правильно понимаю? это весь кусок кода? или есть что-то ещё?
Striker-11
11.01.2012 11:05Ответ № 17
Правильно понимаете, ситуация именно такая... Полный код процедуры, по которой формируется отчёт, приведён немного выше...
ad82117
11.01.2012 11:07Ответ № 18
"На первом рис. группа развернута и в данном случае отчёт формируется нормально...
А вот во втором случае группы свёрнуты, в этом случае в отчёт входит не та информация..." --- при том коде, который Вы выложили - такого быть не должно. переменная "спр" нигде вне модуля не об'явлена?
Striker-11
11.01.2012 11:14Ответ № 19
Данный справочник является подчиненным и данная переменная находится ещё в модуле главного справочника, больше нигде О_о
ad82117
11.01.2012 11:21Ответ № 20
Если Спр.ЭтоГруппа() = 1 Тогда
Таб.ВывестиСекцию("Группа");
ИначеЕсли (Долг>0) Тогда
Таб.ВывестиСекцию("Данные");
КонецЕсли;

давайте для начала переделаем это
Если Спр.ЭтоГруппа() = 1 Тогда
//сюда нужно засунуть все Ваши расчёт касательно групп
Таб.ВывестиСекцию("Группа");
Иначе//если это элемент
//сюда нужно засунуть все Ваши расчёт касательно элементов
Если (Долг>0) Тогда
Таб.ВывестиСекцию("Данные");
КонецЕсли;
КонецЕсли;

+ скрин печатной формы, как в конфигураторе + скрин формы элемента + скрин формы группы
ad82117
11.01.2012 11:26Ответ № 21
а где выполняется условие - если в группе "1" нет элементов с долгом > 0? т.е. просто выводится группа?
Striker-11
11.01.2012 11:45Ответ № 22
Переделал, правд ничего не изменилась... Заметил, что при свернутых группах Долг (Долг=Спр.СуммаКв-Об)не вычисляется, остается равным Спр.СуммаКв, т.е. не вычитается Об
ad82117
11.01.2012 11:56Ответ № 23
давай-те архив сюда
Striker-11
11.01.2012 12:06Ответ № 24
Скачивать файлы может только зарегистрированный пользователь!
Striker-11
11.01.2012 12:07Ответ № 25
Заранее благодарен...
ad82117
11.01.2012 12:25Ответ № 26
я так и думал - поэтому скрины и просил
сделайте "контроль уникальности" и "тип кода" - текстовый для справочника "Дома" --- ИСПОЛЬЗУЙТЕ ТАК ВСЕГДА!!!
перекодируйте элементы в порядке возрастания и посмотрите, чтобы не было одинаковых кодов ни у групп ни у элементов --- это и будет уникальность!
теперь
"Код" - это не номер дома(!!!) - а уникальный код для элемента, который 1С присваивает(!!!).
НИКОГДА ЕГО НЕ ТРОГАТЬ!!!
для КОДА ДОМА ДЕЛАЙТЕ НОВЫЙ РЕКВИЗИТ!!!
для своих "ОбщСуммаЯнв" и еже с ними сделайте на форме элемента реквизит и повесьте на неё функцию для вычисления!
не надо такую конструкцию в отчёте ОбщСуммаЯнв = Спр.СуммаЯнв1+Спр.СуммаЯнв2+Спр.СуммаЯнв3+Спр.СуммаЯнв4
Вы же - программист! )
Striker-11
11.01.2012 12:30Ответ № 27
Честно говоря сам об этом задумывался...) Программист-то программист, но с 1с только начал точнее заставили) Спасибо огромное, буду разбираться!!!
ad82117
11.01.2012 12:48Ответ № 28
и ещё - справочник "Дома" не является подчинённым. поэтому "серии кодов" сделайте "во всём справочнике" + на будущее в свойствах реквизита "код" установите галочку "Запретить редактирование". используйте это и для справочников и для документов. обезопасите себя "от дурака" + есть кнопка "взносы" на форме списка, на ней процедура, в ней ОткрытьФорму("Справочник.Дома.Взносы") - неправильно - ОткрытьФорму("Справочник.Дома") - и не из-за того, что реквизита "Взносы" - нет. посмотрите синтаксис "ОткрытьФорму()"
Striker-11
11.01.2012 17:05Ответ № 29
Я немного не понял про ОткрытьФорму(). Процедура "Взносы" просто открывает второй справочник "Взносы". Что я не так сделал?
Striker-11
11.01.2012 17:05Ответ № 30
Я немного не понял про ОткрытьФорму(). Процедура "Взносы" просто открывает второй справочник "Взносы". Что я не так сделал?
ad82117
11.01.2012 17:39Ответ № 31
1. нет второго справочника "Взносы" в Вашем архиве.
2. ОткрытьФорму(<?>,)
Синтаксис:
ОткрытьФорму(<ОписательОбъекта>,<КонтекстФормы>)
Назначение:
Открывает визуальную форму списка справочника.
Возвращает: 1 - если действие выполнено, 0 - иначе.
Параметры:
<ОписательОбъекта> - строковое выражение. ''Справочник.ХХХХХ.YYYYY'', где ХХХХХ - вид справочника, YYYYY - имя выбранной формы списка справочника;

эта процедура открывает справочник "Дома" с ЯВНО УКАЗАННОЙ формой формы списка! в данном случае это форма называется "Взносы", а справочник всё тот же самый - "Дома"
Striker-11
11.01.2012 17:50Ответ № 32
Всё верно... Кароче, по данной кнопке открывается форма списка "Взносы". Только я все равно не понимаю, что сделал не так (извиняюсь за тупость)))
Кстати, я внёс изменения, о которых вы говорили, вот только проблема с отчётом не решилась(
Изменено 11.01.12 17:51:54
ad82117
12.01.2012 10:34Ответ № 33
на счёт взносов - если так и задумано - тогда всё норм. архив базы давайте ещё раз
Striker-11
12.01.2012 10:45Ответ № 34
Скачивать файлы может только зарегистрированный пользователь!
ad82117
12.01.2012 10:53Ответ № 35
Вы не сделали то, что я вчера писал
где новый реквизит "НомерДома"?
"Код" хоть и уникальный, но не в том формате, который должен быть и Вы не перенумеровали "Код"
Striker-11
12.01.2012 11:01Ответ № 36
Реквизит "НомерДом" я создал, формат кода-текстовый (как Вы и писали)... Может я вам не тот архив отослал? Скачивать файлы может только зарегистрированный пользователь!
ad82117
12.01.2012 14:37Ответ № 37
я что-то не могу найти процедуру "должники". где она живёт?
ad82117
12.01.2012 14:39Ответ № 38
всё. нашёл.
Striker-11
12.01.2012 14:45Ответ № 39
Огромное спасибо за помощь!!! Решил проблему(правда, немного "извращённым" способом)))
ad82117
12.01.2012 15:51Ответ № 40
каким образом?
Striker-11
12.01.2012 16:23Ответ № 41
Создал реквизит "Об" (ранее это была просто переменная в обработке(в формуле Долг=Спр.СуммаКв-Об;)), повесил его на форму элемента, вбил формулу его вычисления и скрыл...
***
У меня к вам еще один вопрос, т.к. вы мне помогали и в курсе всего)) В обработке формируется отчет(процедура ОбщийОтчёт()), так вот мне нужно, вывести в него итоги по каждому дому... К примеру: выводится информация по 1-му дому, под ней секция итог, далее информация по следующему дому и тд.
ad82117
12.01.2012 16:58Ответ № 42
Перем Запрос, ТекстЗапроса, Таб;
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = "
|Без итогов;
|ДомСтрой = Справочник.ДомСтрой.ТекущийЭлемент;
|НомерКвартиры = Справочник.ДомСтрой.НомерКвартиры;
|ФИО = Справочник.ДомСтрой.ФИО;
|Площадь = Справочник.ДомСтрой.Площадь;
|Цена = Справочник.ДомСтрой.Цена;
|СуммаКв = Справочник.ДомСтрой.СуммаКв;
|Договор = Справочник.ДомСтрой.Договор;
|ДатаЗаклДог = Справочник.ДомСтрой.ДатаЗаклДог;
|ДатаРегДог = Справочник.ДомСтрой.ДатаРегДог;
|Функция ПлощадьСумма = Сумма(Площадь);
|Функция ЦенаСумма = Сумма(Цена);
|Функция СуммаКвСумма = Сумма(СуммаКв);
|Группировка ДомСтрой;
|Группировка НомерКвартиры;";
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать1");
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка() = 1 Цикл
Таб.ВывестиСекцию("Сформировать1");
КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать1", "");
ad82117
12.01.2012 17:16Ответ № 43
Вы знаете - Ваша задача не так проста - я по конфигурации в целом
Мне кажется, что надо было делать через документ.
Записывать в регистр и потом уже на основе этого регистра вытаскивать всё, что Вам нужно.

почему я так решил? - сейчас 2012, потом будет 2013, а как Вы своими отчётами разграничите эти года?! или в справочнике "Дома" тогда уж нужно сделать папки уровня 1, обозвать их по годам, а в нижних уровнях собирать все данные за год, а в отчётах указывать папку уровня 1 и дальше по родителю либо вводить периодику на "ОбщСуммаЯнв" и еже с ними и тогда получать значения на дату от года формирования отчётов.

подумайте над этим

а насчёт печатной формы "Должники" - я не уверен, что дело в "Об", т.к. закомментировал весь кусок вычисления и всё равно получается лажа, даже через запрос.
я вижу такое впервые.
что-то в переменных и в самой структуре таблицы. пытаюсь разобраться.
может, конечно, я не знаю какой-то тонкости, но за 10 лет программирования в 7.7 реально с таким сталкиваюсь в первый раз.
Striker-11
12.01.2012 19:43Ответ № 44
Насчёт "сейчас 2012, потом будет 2013" я уже задумывался, но "заказчик" сказал, что взносы поступают максимум в течении 4 месяцев со дня регистрации, да и переход с декабря на январь, так же непринципиален т.к. основная задача данной базы - хранение и формирование отчётов...
***
только что проверил-у меня "должники" корректно формируется, может вы не поняли, как я решил проблему?(т.к. тяжело изъясняться в "письменной" форме)) Могу скинуть архив, если вам интересно...
***
не совсем понял текст запроса... "Группировка" позволяет считать сумму по группам?O_o
ad82117
13.01.2012 09:08Ответ № 45
Скачивать файлы может только зарегистрированный пользователь!
ad82117
13.01.2012 09:12Ответ № 46
только кодировку поменяйте. кнопка "сформировать1" в основной форме списка.
а суммирует функция
|Функция ПлощадьСумма = Сумма(Площадь);
|Функция ЦенаСумма = Сумма(Цена);
|Функция СуммаКвСумма = Сумма(СуммаКв);
группировка - группировочные поля
Striker-11
13.01.2012 10:52Ответ № 47
Хм... Чет не то... Вот, чего я хочу(примерно):
title
Те, чтобы после каждой группы (по номеру дома) были его итоги(не могу построить цикл, отслеживающий изменение "НомерДом" )
И вообще интересно: существует ли какой-нибудь метод в 1с, чтобы с таблицей можно было работать, как с двумерным массивом?
Изменено 13.01.12 11:00:05
ad82117
13.01.2012 14:05Ответ № 48
надо в цикле сделать проверку типа старая группа / новая группа, собирать суммы, потом когда старая группа будет равна новой группе обнулить суммы и снова их считать
Striker-11
13.01.2012 21:42Ответ № 49
Это я понимаю... Для меня проблема и заключается в том, как с помощью цикла отследить изменение группы....
Изменено 16.01.12 11:02:50
ad82117
16.01.2012 12:31Ответ № 50
Скачивать файлы может только зарегистрированный пользователь!
Striker-11
16.01.2012 13:21Ответ № 51
Ого!! Спасибо огромное, что не послали куда подальше)
Изменено 16.01.12 13:22:30
Striker-11
16.01.2012 13:35Ответ № 52
Ругается:
фФИО = СокрЛП(СпрЭ.ФИО.Наименование);
{Справочник.Дома.ФормаСписка.ФормаСписка.Модуль(348)}: Значение не представляет агрегатный объект (Наименование)
Striker-11
16.01.2012 14:03Ответ № 53
Всё, разобрался - доработаю сам... Спасибо огромное за помощь!!!
ad82117
16.01.2012 14:37Ответ № 54
конечно, ругается. сделайте справочник "ФИО" с кодом и наименованием; в элементе справочника "Дома" сделайте реквизит ФИО не строкой, а тип "справочник.фио" и в обработке "ДомСтрой" переименуте в "Дома"
Striker-11
16.01.2012 14:46Ответ № 55
Так и сделал)) Спасиб...
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.