helpf.pro
Регистрация

v8.2 УП: Заполнить реквизиты табличной части

Leshiy
25.01.2012 20:10Прочитано: 5200
Добрый день
Есть УТП 1,2
Автоматически заполняется табличная часть "Заказы покупателей"
Но не заполняются цены, НДС, сумма

Как програмно перезаполнить реквизиты?
Есть такой вариант
"объектДокумент.ПриИзмененииНоменклатурыТоваров(СтрокаТабЧасти);"

Но он не работает
Yandex
Возможно, вас также заинтересует
Реклама на портале
alex81nzp
26.01.2012 06:38Ответ № 1
Я делал кнопку для повышения оклада в кадровом перемещении по всем сотрудникам в документе, может поможет
В Конфигураторе:
1. Создаем внешнюю обработку
2. Создаем Реквизит СсылкаНаОбъект Тип ДокументСсылка.КадровоеПеремещениеОрганизаций (поставьте Ваш вариант)
3. В модуле обработки пишем такой код:
Код 1C v 8.х
 
Процедура Инициализировать (Документ, ИмяТабЧасти, ТабличноеПоле) Экспорт

ТабЧасть = Документ[ИмяТабЧасти];
Оклад = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоЧасам;
СписокВРОклад = Новый СписокЗначений;
СписокВРОклад.Добавить(ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоЧасам);

Для каждого СтрокаТчасти Из ТабЧасть Цикл
Поиск = СписокВРОклад.НайтиПоЗначению(СтрокаТчасти.ВидРасчета);
Если Не Поиск = Неопределено Тогда
СтрокаТчасти.Показатель1 = Окр(СтрокаТчасти.Показатель1*1.08,-1);
КонецЕсли;
КонецЦикла;

КонецПроцедуры

4. Сохраняем
В режиме пользователя:
1. Сервис - Дополнительные отчеты и обработки - Дополнительные обработки табличных частей - Добавить
2. Пишем название, загружаем созданную обработку
3. Добавляем параметры:
Представление документа - Документ в котором нужно разместить кнопку
Табличная часть - Табличная часть с которой работаем
Представление кнопки - Как будет Называться кнопка
Параметры обработки - <Задать параметры> (Вез изменений)
4. Сохраняем и открываем документ, в моем примере Кадровое перемещение
title
iswat
28.04.2013 01:44Ответ № 2
Для управляемого приложения такой метод не подходит
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.