helpf.pro
Регистрация

Как найти пустую строку в табличной части

bless18
12.05.2010 19:45Прочитано: 6621
Здравствуйте!
У меня имеется табличная часть в обработке и мне нужно сделать проверку на наличие пустой строки и указать, какая строка пустая
Пишу процедуру:
Код 1C v 8.х
 Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
Запрос = новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ТекущиеЗадачиСрезПоследних.Отдел,
| ТекущиеЗадачиСрезПоследних.НаименованиеЗадачи,
| ТекущиеЗадачиСрезПоследних.Период
|ИЗ
| РегистрСведений.ТекущиеЗадачи.СрезПоследних КАК ТекущиеЗадачиСрезПоследних";
Результат = Запрос.Выполнить();
ТзВрем = Результат.Выгрузить();
ТзВрем.Колонки.Добавить("Приоритет");
СтрокаТЧ = ЭлементыФормы.РаспределениеЗадачиСотрудникам.ТекущиеДанные;
Для Каждого строка Из ТзВрем Цикл
Если НЕ ЗначениеЗаполнено(СтрокаТаблицыРаспределениеЗадачи) Тогда
Предупреждение("Вы заполнили не все поля!");
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Подскажите, как найти эту самую строку?
Если НЕ ЗначениеЗаполнено(СтрокаТаблицыРаспределениеЗадачи) Это работает для всей табличной части, но незаполненную строку не показывает
Yandex
Возможно, вас также заинтересует
Реклама на портале
szhukov
19.05.2010 19:35Ответ № 1
Лучше не использовать зарезервированные слова типа "строка"

Можно так:
Код 1C v 8.х
 
Для Каждого СтрокаТЗ Из ТзВрем Цикл
Если НЕ (ЗначениеЗаполнено(СтрокаТЗ.Отдел)
И ЗначениеЗаполнено(СтрокаТЗ.НаименованиеЗадачи)
И ЗначениеЗаполнено(СтрокаТЗ.Период) )
Тогда

Предупреждение("Вы заполнили не все поля!");
Возврат;

КонецЕсли;
КонецЦикла;
E_Migachev
19.05.2010 20:50Ответ № 2
szhukov, предложил хороший и рабочий пример, он должен тебе помочь!

на всякий случай выкладываю свой способ:
он просматривает всю таблицу значений и если значение не заполнено, то выводит название пустой колонки:
Код 1C v 8.х
 ТЗврем = ТЧлайскан.Выгрузить();
Для каждого стр из ТЗврем Цикл
ном=0;
Для каждого знч из стр цикл
Если Не ЗначениеЗаполнено(знч) Тогда
Сообщить("Не заполнено значение колонки "+ТЗврем.Колонки[ном].Имя);
КонецЕсли;
ном = ном+1;
КонецЦикла;
КонецЦикла;
Stref75
29.05.2018 11:56Ответ № 3
Вопрос закрыт!
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.