helpf.pro
Регистрация

v7: Конвертация xls в mxl

vlad108
15.02.2012 16:54Прочитано: 3363
Установлены OpenOffice и 1С 7.7.Нужно конвертнуть шаблон из xls в mxl.Excel - не установлен.Посмотрел много обработок на эту тему.Везде создается объект "Excel.Application", но т.к. Excel не установлен, то везде выкидавает ошибку о невозможности создания такого объекта.Вопрос: возможна ли вообще такая конвертация при установленных вышеупомянутых приложениях? Если да, то где можно взять такую обработку?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
15.02.2012 19:22Ответ № 1
(0) vlad108, только взять обработку преобразования xls в mxl и адаптировать под OpenOffice *09
vlad108
15.02.2012 21:26Ответ № 2
(1) E_Migachev, Если честно говорить, то на сегодняшний день я это пока еще плохо себе представляю.
ad82117
17.02.2012 10:24Ответ № 3
Я могу ошибаться, но я не нашёл в https://help1c.com/faq7/cat/42.html того, что хочу предложить Вам для, может быть, решения Вашей проблемы, но, как я понял, Вам нужна
обработка загрузки данных из файла Excel без наличия на компьютере оного - могу посоветовать - http://infostart.ru/public/15610/files/
Очень занимательная штука. сам её использовал на 025 и 027 движке на WinXPSP3Prof.
я бы выложил, но я не правообладатель, думаю немного не этично будет (хотя качал её давно и бесплатно).
Смысл вот в чём - там есть V7XLSD7.dll, её в корень базы и через regsvr32. Всё.
Сам код по созданию объекта и работы с ним (в архиве вроде должен быть пример, но на всякий пожарный. Правда, это кусок из моей обработки, но он с комментариями и разобраться не сложно):
Код 1C v 7.x
 
XLS = СоздатьОбъект("AddIn.XLS");
Мтабл.Очистить();
КоличествоЛистов = XLS.ReadXLS(Расход);//"Расход" это файл формата "xls"
КоличествоСтрок = XLS.RowCount();
КоличествоСтолбцов = XLS.ColCount();
Для СчСтолбцов = 1 По КоличествоСтолбцов Цикл
НаимСтолб = XLS.ReadCell(1,1,СчСтолбцов); //Первый Параметр - хз чё такое (но возвращает "" только на значения "1,2,3". остальное "Ошибка")
//Второй Параметр - строка
//Третий Параметр - номер колонки
Пока СтрЧислоВхождений(НаимСтолб," ") > 0 Цикл
НаимСтолб = СтрЗаменить(СокрЛП(НаимСтолб)," ","");
КонецЦикла;
МТабл.НоваяКолонка(НаимСтолб,,,,,30);
КонецЦикла;
Для СчСтрок = 2 По КоличествоСтрок Цикл
МТабл.НоваяСтрока();
Для СчСтолбцов = 1 По КоличествоСтолбцов Цикл
//Если XLS.GetCellFormula(1,Б,А) <> "" Тогда
//Значение=Строка(XLS.ReadCell(1,Б,А))+" ["+XLS.GetCellFormula(1,Б,А)+"]";
//Иначе
//КонецЕсли;
МТабл.ПолучитьПараметрыКолонки(СчСтолбцов,,,,ВыбЗаголовок,,,);
Значение = XLS.ReadCell(1,СчСтрок,СчСтолбцов);
Если ВыбЗаголовок = "Дата" тогда
Значение = НулеваяДата + Значение;
КонецЕсли;
МТабл.УстановитьЗначение(МТабл.КоличествоСтрок(),СчСтолбцов,Значение);
КонецЦикла;
КонецЦикла;
vlad108
20.02.2012 11:48Ответ № 4
(3) ad82117, Сегодня увидел ваш ответ.Спасибо.По свободе времени обязательно попробую.По вашей ссылке "http://infostart.ru/public/15610/files/" все скачал удачно.Еще раз спасибо.
E_Migachev
20.02.2012 15:19Ответ № 5
ad82117 и vlad108, на всякий случай, размещу это и тут:
Библиотека для работы напрямую с xls-файлами + объемные графики с эффектами для 7.7
Библиотека находится внутри упакованной тестовой базы 1С. Там же 4 демо-отчета.
Автор: Abadonna

Скачивать файлы может только зарегистрированный пользователь!
vlad108
16.03.2012 10:59Ответ № 6
Всем спасибо!
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.