helpf.pro
Регистрация

v8: Печать

Bell
25.02.2012 13:52Прочитано: 2379
Здравствуйте
Подскажите вот установил кнопки меню печати ,но они не активны (все работает можно длелать выбор, кнопку по умолчанию ) Как их активизировать, что бы связать с функцией печати таб.дока.
В модуле объекта написал все процедуры и что то не так
Код 1C v 8.х
 Процедура УстановитьКнопкиПечати()

мДеревоМакетов = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Ссылка, ПолучитьСтруктуруПечатныхФорм(), Новый Действие("ОсновныеДействияФормыПечать"), Новый Действие("ОсновныеДействияФормыУстановитьПечатьПоУмолчанию"));

УниверсальныеМеханизмы.УстановитьПодменюПечати (мПодменюПечати, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов.Строки.Количество() > 0);
УниверсальныеМеханизмы.УстановитьПечатьПоУмолчанию(мПечатьПоУмолчанию, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов, Метаданные().Имя,Новый Действие("ОсновныеДействияФормыПечатьПоУмолчанию"));

Если Не мПодменюПечати = Неопределено Тогда
УниверсальныеМеханизмы.СформироватьПодменю(мДеревоМакетов, мПодменюПечати,Истина,Истина);
КонецЕсли;

КонецПроцедуры


МОДУЛЬ ОБъекта

Код 1C v 8.х
 Функция ПечатьПКО(НазваниеМакета) 

ТабДок = Новый ТабличныйДокумент;
Макет = ПолучитьОбщийМакет("ПКО");
ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
ТабДок.Вывести(ОбластьМакета);
Возврат ТабДок;

КонецФункции


Код 1C v 8.х
 Процедура Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь, НепосредственнаяПечать = Ложь) Экспорт

Если ИмяМакета = "ПКО" Тогда
ТабДок = ПечатьПКО(ИмяМакета);
ИначеЕсли ИмяМакета="ПКОвал" Тогда
ТабДок = ПечатьПКОвал(ИмяМакета);
КонецЕсли;

УниверсальныеМеханизмы.НапечататьДокумент(ТабДок, КоличествоЭкземпляров, НаПринтер, ,НепосредственнаяПечать);

КонецПроцедуры

Код 1C v 8.х
 Функция ПолучитьСтруктуруПечатныхФорм() Экспорт

Возврат Новый Структура("ПКО,ПКОвал","Приходно-кассовый ордер","Приходно-кассовый ордер (валютный)");

КонецФункции

Изменено 25.02.12 13:54:50
Yandex
Возможно, вас также заинтересует
Реклама на портале
Bell
26.02.2012 12:56Ответ № 1
Нашел что не доделал
Mokey
28.02.2012 10:04Ответ № 2
Ага, в форме документа скорее всего не было процедуры ПечатьПоУмолчанию()
Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.