helpf.pro
Регистрация

v8: Удаление Перфикса

Bell
29.02.2012 16:20Прочитано: 2139
Здравствуйте
Не получается удалить префиксы в номере документа
Пробовал разными способами не идет

Код 1C v 8.х
 Функция ПолучитьНомерНаПечать(Документ) Экспорт

Если Документ = Неопределено Тогда
Возврат 0;
КонецЕсли;

Номер = СокрЛП(Документ.Номер);
Префикс="";
// удаление префикса из номера документа

Если Найти(Номер, Префикс)=1 Тогда
Номер = Сред(Номер, СтрДлина(Префикс)+1);
КонецЕсли;

// так же, может остаться "минус" впереди
Если Лев(Номер, 1) = "-" Тогда
Номер = Сред(Номер, 2);
КонецЕсли;

// удаление ведущих нулей
Пока Лев(Номер, 1)="0" Цикл
Номер = Сред(Номер, 2);
КонецЦикла;

Возврат Номер;

КонецФункции
Yandex
Возможно, вас также заинтересует
Реклама на портале
Mokey
01.03.2012 11:47Ответ № 1
Не понял, а где префикс, который ищем???
Префикс="";
Bell
01.03.2012 12:44Ответ № 2
Сделал так вроде на все случаи жизни АБ-СД-А09 вывод 9
Что можно еще учесть
Символы тоже убивает
Код 1C v 8.х
 Функция ПолучитьНомерНаПечать(Документ) Экспорт

Если Документ = Неопределено Тогда
Возврат 0;
КонецЕсли;

Номер = СокрЛП(Документ);

Префикс=Найти(Номер,"0");
Номер=Сред(Номер,Префикс+1);

// так же, может остаться "минус" впереди
Если Лев(Номер, 1) = "-" Тогда
Номер = Сред(Номер, 2);
КонецЕсли;

// удаление ведущих нулей
Пока Лев(Номер, 1)="0" Цикл
Номер = Сред(Номер, 2);
КонецЦикла;

Возврат Номер;

КонецФункции

Изменено 01.03.12 13:08:43
Bell
03.03.2012 11:06Ответ № 3
Вопрос закрыт!
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.