helpf.pro
Регистрация

v8: выгрузка данных из 1С 8.2 в excel

Natall
16.03.2012 00:53Прочитано: 15406
Как выгрузить данные из 1с 8.2 в виде СНД и СКД по счетам (01,02,10 и т.д.), т.е. баланс в имеющийся файл excel для финансового анализа
Yandex
Возможно, вас также заинтересует
Реклама на портале
odinson
16.03.2012 14:29Ответ № 1
Код 1C v 8.2 УП
 
Процедура ДействияФормыЗаписатьВExcel(Кнопка)
если ПутьФайла = "" тогда
Режим = РежимДиалогаВыбораФайла.Сохранение;
ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
ДиалогОткрытияФайла.ПолноеИмяФайла = "";
ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
ДиалогОткрытияФайла.Заголовок = "Выведите имя файла.)";
ДиалогОткрытияФайла.Фильтр = "Файл Excel |*.XLS";
Если ДиалогОткрытияФайла.Выбрать() Тогда
ПутьФайла = ДиалогОткрытияФайла.ПолноеИмяФайла;
Иначе
Предупреждение("Каталог не выбран!");
Возврат;
КонецЕсли;
КонецЕсли;

ЭлементыФормы.ПолеТабличногоДокумента.Записать(ПутьФайла,ТипФайлаТабличногоДокумента.XLS);

КонецПроцедуры
Natall
17.03.2012 21:06Ответ № 2
(1) odinson, Это всё куда нужно прописать?
DJ_Serega
18.03.2012 03:10Ответ № 3
(2) Natall, "тут вопрос в другом. Тебе нужно в Экселе найти ячейки куда данные записывать? Отдельно на новый лист?

Вышеприведенный код решает вопрос к поиску и выбора файла XLS. А как именно писать данные могу привести пример, только вечером както )
Natall
02.04.2012 06:40Ответ № 4
DJ_Serega, у меня уже есть файл exceL, в нем есть баланс со всеми формами и финанализом.
На листе 1 сам баланс. В ячейку, например, C2 мне нужно записать из 1с 8.2 сальдо нач. деб. 10 счета, в С3 (например) с-до конечное деб 10 счета и т.д.
Mokey
02.04.2012 11:33Ответ № 5
1. Открыть книгу
2. Активировать нужный лист
3. Далее по адресам ячеек...
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.