helpf.pro
Регистрация

v8: В чем ошибка?

kosvo
02.04.2012 10:44Прочитано: 3021
Доброго времени суток!
Помогите пожалуйста разобраться! При создании нового запроса выдает постоянно ошибку..., причем , даже если вводится пример из справки.

=========================
&НаКлиенте

Процедура сталь_055ПриИзменении(Элемент)

Запрос = Новый Запрос();
Запрос.Текст = "ВЫБРАТЬ
| Номенклатура.Ссылка
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.Услуга";

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл
Сообщить(Выборка.Ссылка);
КонецЦикла;

КонецПроцедуры
================================

Выдает ошибку:

{ОбщаяФорма.Вариант.Форма(6,16)}: Тип не определен (Запрос)
Запрос = Новый <<?>>Запрос();


Учусь в ДемоВерсии 1С.v8

Спасибо!
Yandex
Возможно, вас также заинтересует
Реклама на портале
Mokey
02.04.2012 11:31Ответ № 1
Что первое в голову пришло, буквы Рус-Лат какие-то в слове "Запрос".
Изменено 02.04.12 11:31:47
E_Migachev
02.04.2012 11:42Ответ № 2
(0) kosvo,
1. Пишется:
Код 1C v 8.х
 Запрос = Новый Запрос;   

2. Если это УП, то Запрос можно выполнять только на сервере
Mokey
02.04.2012 11:43Ответ № 3
(2) E_Migachev, вроде же и со скобками работает...

... проверил у себя (засомневался было), всё работает со скобками.
Изменено 02.04.12 11:45:04
kosvo
02.04.2012 11:53Ответ № 4
т.е. причина в "&НаКлиенте" ?
E_Migachev
02.04.2012 12:04Ответ № 5
(3) Mokey, хорошо ), я всегда без () пишу...
(4) kosvo, да
Mokey
02.04.2012 12:37Ответ № 6
Ух ты.. а я и не обратил внимание на &НаКлиенте... сорри
kosvo
02.04.2012 12:47Ответ № 7
Всем СПАСИБО!
kosvo
02.04.2012 12:47Ответ № 8
Вопрос закрыт!
DJ_Serega
03.04.2012 11:59Ответ № 9
(5) E_Migachev,
Я обычно так пишу запросы:
Код 1C v 8.х
 
Процедура БлаБлаБла
Запрос = Новый Запрос(ПолучитьТекстЗапроса());
КонецПроцедуры

Функция ПолучитьТекстЗапроса()
ТекстЗапроса =
"БлаБлаБла"
;
Возврат ТекстЗапроса;
КонецФункции


Текст получается компакнтым, и все запросы отдельно написаны в модуле объекта, изза чего можно их использовать из других объектов *07
Изменено 03.04.12 12:02:47
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.