helpf.pro
Регистрация

v8: Разграничение прав

Ermak
24.04.2012 16:30Прочитано: 5484
Пытаю разграничить права в форме списка справочника Номенклатура

Код 1C v 8.х
 
Спр = Справочники.Номенклатура;
Если ПараметрыСеанса.ТекущийПользователь.Наименование = "Иван" Тогда
ЭтаФормы.Отбор.Наименование.Значение = Спр.НайтиПоНаименованию("Папирус")
ЭтаФормы.Отбор.Наименование.Использование = Истина;
КонецЕсли;
ЭлементыФормы.Список.НастройкаОтбора.Наименование.Доступность = Ложь;


Выдает ошибку Ошибка при установке значения атрибута контекста (Значение)
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
24.04.2012 20:29Ответ № 1
(0) Ermak, это отбор чего ты хочешь установить? что на форме?
Ermak
25.04.2012 08:17Ответ № 2
Отбор хочу сделать по наименованию, чтобы пользователи могли открывать только свою группу
Ermak
25.04.2012 08:19Ответ № 3
и можете подсказать как сделать чтобы при открывании пользователем справочника Номенклатура открывалась сразу его группа (Например: Папирус)
E_Migachev
25.04.2012 08:29Ответ № 4
как-то так *09
Код 1C v 8.х
  СправочникСписок.Отбор.Сбросить();
СправочникСписок.Отбор.Наименование.ВидСравнения=ВидСравнения.ВИерархии;
СправочникСписок.Отбор.Наименование.Значение= Спр.НайтиПоНаименованию("Папирус");
СправочникСписок.Отбор.Наименование.Установить();
Ermak
25.04.2012 13:57Ответ № 5
Код 1C v 8.х
 Процедура ПриОткрытии()


Спр = Справочники.Номенклатура;
Если ПараметрыСеанса.ТекущийПользователь.Наименование = "Иван" Тогда

Список.Отбор.Сбросить();
Список.Отбор.Наименование.ВидСравнения = ВидСравнения.ВИерархии;
Список.Отбор.Наименование.Значение = Спр.НайтиПоНаименованию("Папирус");
Список.Отбор.Наименование.Установить();
КонецЕсли;
ЭлементыФормы.Список.НастройкаОтбора.Наименование.Доступность = Ложь;
КонецПроцедуры

Выдает ошибук:

{Справочник.Номенклатура.Форма.ФормаСписка.Форма(19)}: Ошибка при установке значения атрибута контекста (ВидСравнения)
Список.Отбор.Наименование.ВидСравнения = ВидСравнения.ВИерархии;

Изменено 25.04.12 13:57:57
Ermak
27.04.2012 15:14Ответ № 6
подскажите!
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.