helpf.pro
Регистрация

v8: Как убрать все символы до знака -

Farmar
27.04.2012 09:53Прочитано: 1450
Есть строка в табличной части с таким текстом "HPA-C8543X", нужно убрать все символы до символа "-".
НовСимвол = "";
НужныйСимвол = "-";
Для Сч = 1 по СтрДлина(Стр.КодТовара) Цикл
НужныйСимвол = НужныйСимвол + 1;
КодСимвола = КодСимвола(Сред(Стр.КодТовара, Сч, 1));
Если Сред(Стр.КодТовара, Сч, 1) <> НужныйСимвол Тогда
Продолжить;
КонецЕсли;
КонецЦикла;
Стр.КодТовара = Сред(Стр.КодТовара, НовСимвол);
Это не работает)
Yandex
Возможно, вас также заинтересует
Реклама на портале
ad82117
27.04.2012 10:09Ответ № 1
разбирайте строку
1. получите всю длину строки
2. получите позицию знака "-"
3. отнимите или верните оставшееся количество символов
Ramzes7000
27.04.2012 10:20Ответ № 2
Процедура КнопкаВыполнитьНажатие(Кнопка)

лпРезультат = "";
лпОбрезали = 0;
лпИсточник = СокрЛП(ПолеВвода1);
Для Сч = 1 по СтрДлина(лпИсточник) Цикл
лпСимвол = Сред(лпИсточник, Сч, 1);
Если лпОбрезали = 0 Тогда
Если лпСимвол = "-" Тогда
лпОбрезали = 1;
КонецЕсли;
Продолжить;
КонецЕсли;
лпРезультат = лпРезультат + лпСимвол;
КонецЦикла;
ПолеВвода1 = лпРезультат;
КонецПроцедуры
Ramzes7000
27.04.2012 10:22Ответ № 3
Или так

Процедура КнопкаВыполнитьНажатие(Кнопка)

лпИсточник = СокрЛП(ПолеВвода1);
ПолеВвода1 = Прав(лпИсточник, СтрДлина(лпИсточник) - Найти(лпИсточник, "-"));

КонецПроцедуры
Mokey
27.04.2012 10:27Ответ № 4
Или так

Процедура КнопкаВыполнитьНажатие(Кнопка)

ОбрезаннаяСтрока = Сред(ИскомаяСтрока, Найти(ИскомаяСтрока, "-") + 1);

КонецПроцедуры
Farmar
27.04.2012 10:29Ответ № 5
Так будет вернее.

НовСимвол = "";

НужныйСимвол = "-";
Для Сч = 1 по СтрДлина(Стр.КодТовара) Цикл

Если Сред(Стр.КодТовара, Сч, 1) = НужныйСимвол Тогда
Стр.КодТовара = СтрЗаменить(Стр.КодТовара, Сред(Стр.КодТовара, 1, Сч), НовСимвол);
Прервать;
КонецЕсли;
КонецЦикла;
Farmar
27.04.2012 10:31Ответ № 6
Спасибо за советы, разобрался!
Mokey
27.04.2012 10:39Ответ № 7
Зачем циклить, если одна функция всё это делает?
Удачи!
Farmar
27.04.2012 13:34Ответ № 8
Вопрос закрыт!
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.