helpf.pro
Регистрация

v8: Помогите рразобраться с кодом на 7.7 чтобы его переписать на 8.2

russinka
16.05.2012 11:01Прочитано: 2574
//*******************************************
Процедура Сформировать()
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
Таб.ВывестиСекцию("Шапка1");

док=СоздатьОбъект("Документ.СчетФактураВыданный");
док.ВыбратьДокументы(НачДата,КонДата);


Пока Док.ПолучитьДокумент()=1 Цикл

ДокОснов=Док.ДокументОснование;
Если Док.УчитыватьНДС <> 1 Тогда

Таб.ВывестиСекцию("Строка");
КонецЕсли;

КонецЦикла;


Таб.Опции(0,0,0,0);
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать","");
КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
russinka
16.05.2012 11:02Ответ № 1
Ни как не могу понять, как его переписать на 8.2, это внешняя обработка
E_Migachev
16.05.2012 11:18Ответ № 2
(1) russinka, посмотрите здесь: Как сформировать Тбличный документ в 8.2
russinka
16.05.2012 11:54Ответ № 3
Почти разобралась но не работает Таб.Показать("Сформировать",""); Что делать? Это внешняя обработка(((
E_Migachev
22.05.2012 10:30Ответ № 4
(3) russinka, попробуй Таб.Показать();
или покажи весь свой код
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.