helpf.pro
Регистрация

v8.2 УП: Загрузка ПКО

Ponomarenko
06.06.2012 09:26Прочитано: 2722
Здравствуйте. У нас программа 1С УПП 8.2. Я загружаю из DBF файла данные в документ Приходно-кассовый ордер. Подскажите как правильно загрузить данные в табличную часть документа.
Код 1C v 8.2 УП
    

ВыбранныйОтветственный = Справочники.Пользователи.НайтиПоНаименованию("Пономаренко");
ВыбраннаяОрганизация = Справочники.Организации.НайтиПоКоду("000000001");
ВыбранныйСчет = Справочники.БанковскиеСчета.НайтиПоКоду("000000007");
ВыбраннаяКасса=Справочники.Кассы.НайтиПоКоду("000000001");
сообщить(" ВыбранныйОтветственный= "+ВыбранныйОтветственный+" ВыбраннаяОрганизация= "+ВыбраннаяОрганизация+" ВыбранныйСчет= "+ВыбранныйСчет );

//ВыбранныйДоговор = Справочники.ДоговорыКонтрагентов.НайтиПоКоду("00013");
//ВыбранныйДокумент = Документы.ДокументРасчетовСКонтрагентом.НайтиПоНомеру(2, '20050101');

//ВыбраннаяСтатья = Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоКоду("00002");
ВыбраннаяВалюта = Справочники.Валюты.НайтиПоКоду(810);




БД = Новый XBase;
БД.ОткрытьФайл("C:\PKO.DBF");
БД.Первая();
//БД.Перейти(17166);
Пока БД.Следующая() Цикл
// Создать будущий регистратор.

ДатаЗаписи = ТекущаяДата();
Документ = Документы.ПриходныйКассовыйОрдер.СоздатьДокумент();
ВыбранныйКонтрагент = Справочники.Контрагенты.НайтиПоКоду(БД.KONTR);
Документ.Дата = БД.DATA;
Документ.Организация = ВыбраннаяОрганизация;
Документ.Ответственный = ВыбранныйОтветственный;
Документ.Комментарий = "Ввод документов из 1С Комплексной 7.7";
Документ.Касса=ВыбраннаяКасса;
Документ.ОтражатьВБухгалтерскомУчете=1;
Документ.ОтражатьВНалоговомУчете=1;
Документ.ОтражатьВУправленческомУчете=1;
Документ.ОтраженоВОперУчете=1;
Документ.Оплачено=1;
Документ.ПринятоОт=сокрЛП(БД.PRINATO);
Документ.Основание=сокрЛП(БД.OSNOV);
Документ.Контрагент=ВыбранныйКонтрагент;
Документ.СуммаДокумента=БД.SUMMA;
Если БД.NDS="" Тогда
Документ.СтавкаНДС=Перечисления.СтавкиНДС.БезНДС;
иначеЕсли Документ.СтавкаНДС=18 Тогда
Документ.СтавкаНДС=Перечисления.СтавкиНДС.НДС18;
конецесли;
Если сокрЛП(БД.KODOPER)="2111" Тогда
Документ.ВидОперации=Перечисления.ВидыОперацийПКО.ОплатаПокупателя;
ИначеЕсли сокрЛП(БД.KODOPER)="2224" Тогда
Документ.ВидОперации=Перечисления.ВидыОперацийПКО.ПриходДенежныхСредствПрочее;

КонецЕсли;

Если БД.DVIGEN=205 Тогда
ВыбраннаяСтатья=Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоКоду("10101041");
ИначеЕсли БД.DVIGEN=7 Тогда
ВыбраннаяСтатья=Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоКоду("105");
иначе
сообщить("не нашла статью"+БД.DVIGEN);
КонецЕсли;
сообщить(ВыбраннаяСтатья);
Документ.СтатьяДвиженияДенежныхСредств=ВыбраннаяСтатья ;

Документ.СчетОрганизации=ВыбранныйСчет;

Документ.РасшифровкаПлатежа.Добавить();
Если БД.SCHZATR="51" Тогда
Документ.СчетУчетаРасчетовСКонтрагентом=ПланыСчетов.Хозрасчетный.НайтиПоКоду("51");
Документ.СубконтоКт1=ВыбранныйСчет;
Документ.СубконтоКт2=ВыбраннаяСтатья;
//Документ.РасшифровкаПлатежа.СуммаВзаиморасчетов=БД.SUMMA;

иначе
Документ.СчетУчетаРасчетовСКонтрагентом=ПланыСчетов.Хозрасчетный.НайтиПоКоду("60.01");
Документ.СчетУчетаРасчетовСКонтрагентом=ПланыСчетов.Хозрасчетный.НайтиПоКоду("60.01");

//Документ.РасшифровкаПлатежа.СчетУчетаРасчетовПоАвансам=ПланыСчетов.Хозрасчетный.НайтиПоКоду("60.02");

КонецЕсли;

Документ.ВалютаВзаиморасчетовПодотчетника= ВыбраннаяВалюта;
Документ.ВалютаДокумента=ВыбраннаяВалюта;
Документ.КратностьДокумента=1;
Документ.КурсДокумента=1;
Документ.мВалютаРегламентированногоУчета=ВыбраннаяВалюта;

Документ.ЕстьРасчетыПоКредитам=1;
Документ.ЕстьРасчетыСКонтрагентами=1;

//Документ.
Документ.Записать();



КонецЦикла;
БД.ЗакрытьФайл();


КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
Mokey
07.06.2012 12:13Ответ № 1
а в чём, собственно, проблема? ошибку выдаёт или что?
Ponomarenko
24.10.2012 11:51Ответ № 2
Вопрос закрыт!
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.