helpf.pro
Регистрация

v8: Пользователи

Bell
07.06.2012 16:49Прочитано: 1437
Здравствуйте
Записываю настройки пользователя в Хранилище значения

Код 1C v 8.х
 Процедура  ЗаписатьНастройкиПользователяИБ()
СтруктураПараметров = Новый Структура;
СтруктураПараметров.Вставить("Имя" , Код);
//****т.д.
СписокРолей = Новый СписокЗначений;
Для Каждого Роль Из СписокДоступныхРолейПользователяБД Цикл
Если Роль.Пометка Тогда
СписокРолей.Добавить(Роль.Значение.Имя);
КонецЕсли;
КонецЦикла;

СтруктураПараметров.Вставить("СписокРолей", СписокРолей);

ХранилищеПараметровПользователяИБ = Новый ХранилищеЗначения(СтруктураПараметров);

РаботаСпользователями.ЗаписатьНастройкиУчетнойЗаписиПользователяВРегистр(Ссылка,ХранилищеПараметровПользователяИБ);
КонецПроцедуры


Теперь хочу получть значения из хранилище при открытии элемента справочника Пользоватлеи
Код 1C v 8.х
 Процедура ОбновитьПараметрыПользователяИБ()

СтруктураПараметров = ХранилищеПараметровПользователяИБ.Получить();
// т.д ***
СписокРолей = СтруктураПараметров.СписокРолей;

Для Каждого СтрокаРолей Из СписокДоступныхРолейПользователяБД Цикл
СтрокаРолей.Пометка = (СписокРолей.НайтиПоЗначению(СтрокаРолей.Значение.Имя) <> Неопределено);
КонецЦикла;


КонецПроцедуры


Код 1C v 8.х
 Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)


ОбновитьПараметрыПользователяИБ();

КонецПроцедуры



Ругается что переменная не определена. Ставлю переменную в скобки процедуры. .в процедуре ОбновитьПараметрыПользователяИБ ошибки нет, в процедуре Перед открытием есть. КАК СДЕЛАТЬ ГРАМОТНО НЕ МОГУ РАЗОБРАТЬСЯ
Изменено 07.06.12 16:50:50
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
08.06.2012 13:56Ответ № 1
(0) Bell, а поставить в При открытии
Bell
08.06.2012 15:46Ответ № 2
Это ошибка
{Справочник.Пользователи.Форма.ФормаЭлемента.Форма(28,37)}: Переменная не определена (ХранилищеПараметровПользователяИБ)
ОбновитьПараметрыПользователяИБ(<<?>>ХранилищеПараметровПользователяИБ); (Проверка: Толстый клиент (обычное приложение))

Код 1C v 8.х
 Процедура ОбновитьПараметрыПользователяИБ(ХранилищеПараметровПользователяИБ = Неопределено) параметр добавил .

// Сама процедура
конецПроцедуры

Как передать этот параметр в процедуру с процедуров в ПриОткрытии() или ПередОткрытим(). Может есть какая нибудь глобальная перменная не могу понять. Основываюсь на базе Книжный магазин
Изменено 08.06.12 15:47:52
E_Migachev
08.06.2012 17:27Ответ № 3
у тебя запись идет через общий модуль РаботаСпользователями:
Код 1C v 8.х
 РаботаСпользователями.ЗаписатьНастройкиУчетнойЗаписиПользователяВРегистр(Ссылка,ХранилищеПараметровПользователяИБ);   

посмотри его, там наверняка есть процедура или функция получения настроек
Bell
12.06.2012 11:39Ответ № 4
Сделал без экспорта все пошло
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.