helpf.pro
Регистрация

v8: Печать

Bell
09.08.2012 12:48Прочитано: 2233
Здравствуйте
Скажите что не так. Почему не выводит параметры печати в общую форму
Отладчик говорит что передают их

Код 1C v 8.х
 Функция ПечатьПКОвал(НазваниеМакета) 

ТабДок = Новый ТабличныйДокумент;
Макет = ПолучитьОбщийМакет("ПКОвал");

ТабДок.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТЬ_ПКОвал";
ТабДок.ПолеСверху = 5;
ТабДок.ПолеСнизу = 5;
ТабДок.ПолеСлева = 20;
ТабДок.ПолеСправа = 5;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;

Если НазваниеМакета = "ПКОвал" Тогда
ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
ОбластьМакета.Параметры.Заполнить(ОбластьМакета);
ТабДок.Вывести(ОбластьМакета);
КонецЕсли;

Возврат ТабДок;

КонецФункции


Процедура общей формы

Код 1C v 8.х
 Процедура ПриОткрытии()

ОбновитьДанные();

ЭлементыФормы.ПолеДокумента.ОтображатьЗаголовки = Ложь;
ЭлементыФормы.ПолеДокумента.ОтображатьСетку = Ложь;
ЭлементыФормы.ПолеДокумента.Защита = Ложь;
ЭлементыФормы.ПолеДокумента.ТолькоПросмотр = Истина;
ЭлементыФормы.ПолеДокумента.ИмяПараметровПечати = ПечатныйДокумент.ИмяПараметровПечати;
ЭлементыФормы.ПолеДокумента.ЧерноБелыйПросмотр = Ложь;
ЭлементыФормы.ПолеДокумента.ЧерноБелаяПечать = Истина;
ЭлементыФормы.ПолеДокумента.ПовторятьПриПечатиСтроки = ПечатныйДокумент.ПовторятьПриПечатиСтроки;
ЭлементыФормы.КоманднаяПанель.Кнопки.ТолькоПросмотр.Пометка = Истина;

КоличествоКопий = Макс(ЭлементыФормы.ПолеДокумента.КоличествоЭкземпляров, 1);

КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
09.08.2012 17:59Ответ № 1
(0) Bell, а что ты хочешь сделать?
Bell
09.08.2012 23:38Ответ № 2
Я хочу в поле ТАБЛИЧНОГО документа на общей форме передать параметры печати, отступы и т.д. Вроде все правильно все сделал В возрате функции параметры печати идут, в общей форме ИмяПараметровПечати идет, а смотрю параметры печати через меню файл, ничего не изменяется. Я в иете сморел у людей тоже были таки проблемы, но кто то решел их через

ТабДок.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТЬ_ПКОвал";
ТабДок.ПолеСверху = 5;
ТабДок.ПолеСнизу = 5;
ТабДок.ПолеСлева = 20;
ТабДок.ПолеСправа = 5;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
А у кого то не получилось . Вот у меня и нет может это есть какой то глюк в платформе
, а если нет, то что надо посмотреть и сверить еще..
Изменено 09.08.12 23:40:28
E_Migachev
10.08.2012 10:50Ответ № 3
(2) Bell, установи эти параметры для поля табличного документа, перед или после вывода информации
Bell
13.08.2012 17:21Ответ № 4
1. Если в общей форме добавить
ЭлементыФормы.ПолеДокумента.ПолеСверху = ПечатныйДокумент.ПолеСверху;
и т.д. то параметры передаются
В общем вопрос снят

2.Но я смортел БП 2.0 , а там нет передачи параметра там.достаточно утановить параметры в модуле объекта документа. Просто интересно что все таки не так.
Изменено 13.08.12 17:22:27
E_Migachev
13.08.2012 17:33Ответ № 5
(4) Bell, скорее всего в модуле уже обрабатывается ЭлементыФормы.ПолеДокумента
Bell
13.08.2012 21:04Ответ № 6
Вопрос закрыт!
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.