helpf.pro
Регистрация

v8.2 УП: замена значений в задачах

asdfr1
10.08.2012 10:29Прочитано: 1107
внешняя обработка.Необходимо заменить одно значение на другое.Проводок нет.Выбираю запросом
Что = ЭтаФорма.ЭлементыФормы.Что.Значение;
КонтрольнаяДата = ТекущаяДата();
НаКого = ЭтаФорма.ЭлементыФормы.НаКого.Значение;


Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Задача.Ссылка КАК Ссылка,
| Задача.Представление,
| Задача.ТочкаМаршрута,
| ПРЕДСТАВЛЕНИЕ(Задача.ТочкаМаршрута),
| Задача.Наименование,
| Задача.Пользователь КАК Пользователь1,
| ПРЕДСТАВЛЕНИЕ(Задача.Пользователь),
| Задача.Создатель,
| ПРЕДСТАВЛЕНИЕ(Задача.Создатель),
| Задача.БизнесПроцесс.Номер
| ИЗ
| Задача.Задача КАК Задача
| ГДЕ

| Задача.Выполнена = ЛОЖЬ
| И Задача.КонтрольныйСрок < &КонтрольнаяДата
| И Задача.Пользователь = &Что
|
|ДЛЯ ИЗМЕНЕНИЯ";

а дальше непонятки :
Для каждого Строка Из ТЗ Цикл
Объект = Строка.Ссылка.ПолучитьОбъект();
Для каждого Строка Из ТЗ Цикл

Заменяемые.Вставить(Что, НаКого);
Объект.Записать();
КонецЦикла; КонецЦикла;

и не записывает )
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
10.08.2012 10:56Ответ № 1
(0) asdfr1, а что ты хочешь поменять-то? что такое ТЗ?
asdfr1
10.08.2012 11:10Ответ № 2
Для каждого Строка Из ТЗ Цикл
Объект = Строка.Ссылка.ПолучитьОбъект();


Объект.Пользователь = НаКого;


Объект.Записать();
КонецЦикла; КонецЦикла;
asdfr1
10.08.2012 11:18Ответ № 3
тз таблица значений, туплю не пойму каким механизмом это сделать
E_Migachev
10.08.2012 14:14Ответ № 4
(3) asdfr1, а где выборка из запроса? покажи весь код
asdfr1
10.08.2012 15:47Ответ № 5
Что = ЭтаФорма.ЭлементыФормы.Что.Значение;
КонтрольнаяДата = ТекущаяДата();
НаКого = ЭтаФорма.ЭлементыФормы.НаКого.Значение;



Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Задача.Ссылка КАК Ссылка,
| Задача.Представление,
| Задача.ТочкаМаршрута,
| ПРЕДСТАВЛЕНИЕ(Задача.ТочкаМаршрута),
| Задача.Наименование,
| Задача.Пользователь КАК Пользователь1,
| ПРЕДСТАВЛЕНИЕ(Задача.Пользователь),
| Задача.Создатель,
| ПРЕДСТАВЛЕНИЕ(Задача.Создатель),
| Задача.БизнесПроцесс.Номер
| ИЗ
| Задача.Задача КАК Задача
| ГДЕ

| Задача.Выполнена = ЛОЖЬ
| И Задача.КонтрольныйСрок < &КонтрольнаяДата
| И Задача.Пользователь = &Что
|
|ДЛЯ ИЗМЕНЕНИЯ";

Запрос.УстановитьПараметр("КонтрольнаяДата", КонтрольнаяДата);
Запрос.УстановитьПараметр("Что", Что);

Результат = Запрос.Выполнить();

//ТаблицаЗаполнения = Запрос.Выполнить().Выгрузить();
ТЗ = Результат.Выгрузить();
ОткрытьЗначение(ТЗ);

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Заменяемые = Новый Соответствие;



Для каждого Строка Из ТЗ Цикл
Объект = Строка.Ссылка.ПолучитьОбъект();
Объект.Пользователь = НаКого;

Сообщить(Объект.Исполнитель);

//
//Заменяемые.Вставить(Что, НаКого);
Объект.Записать();
КонецЦикла; КонецЦикла;
выборки то и нет

*08
E_Migachev
10.08.2012 17:00Ответ № 6
мдя *09, попробуй так
Код 1C v 8.х
 Что = ЭтаФорма.ЭлементыФормы.Что.Значение; 
КонтрольнаяДата = ТекущаяДата();
НаКого = ЭтаФорма.ЭлементыФормы.НаКого.Значение;

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Задача.Ссылка КАК Ссылка,
| Задача.Представление,
| Задача.ТочкаМаршрута,
| ПРЕДСТАВЛЕНИЕ(Задача.ТочкаМаршрута),
| Задача.Наименование,
| Задача.Пользователь КАК Пользователь1,
| ПРЕДСТАВЛЕНИЕ(Задача.Пользователь),
| Задача.Создатель,
| ПРЕДСТАВЛЕНИЕ(Задача.Создатель),
| Задача.БизнесПроцесс.Номер
| ИЗ
| Задача.Задача КАК Задача
| ГДЕ

| Задача.Выполнена = ЛОЖЬ
| И Задача.КонтрольныйСрок < &КонтрольнаяДата
| И Задача.Пользователь = &Что
|
|ДЛЯ ИЗМЕНЕНИЯ";

Запрос.УстановитьПараметр("КонтрольнаяДата", КонтрольнаяДата);
Запрос.УстановитьПараметр("Что", Что);

ТЗ = Запрос.Выполнить().Выгрузить();

Для каждого Строка Из ТЗ Цикл
Объект = Строка.Ссылка.ПолучитьОбъект();
Объект.Пользователь = НаКого;
Сообщить(Объект.Исполнитель);
Объект.Записать();
КонецЦикла; КонецЦикла;
asdfr1
10.08.2012 22:02Ответ № 7
СПС , точно *06 *01
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.