helpf.pro
Регистрация

v8: Колво движений не соответствует колву строк в документе - почему?

noook
14.08.2012 10:28Прочитано: 953
Колво движеий не соответствует колву строк в документе - почему?
Делаю так:
Код 1C v 8.х
 Процедура ОбработкаПроведения(Отказ, РежимПроведения)
Движения.ПроцессыОповещения.Записывать = Истина;
Для Каждого ТекСтрокаТЧ_ПроцессаОповещения Из ТЧ_ПроцессаОповещения Цикл
Движение = Движения.ПроцессыОповещения.Добавить();
Движение.Заказчик = Заказчик;
Движение.АвторДокумента = ПользователиИнформационнойБазы.ТекущийПользователь();
Движение.СтатусАктивность = ИСТИНА;
КонецЦикла;
КонецПроцедуры

Почему делается только одна запись в регистре, хотя в документе строк может быть больше?
Изменено 14.08.12 13:08:53
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
14.08.2012 13:08Ответ № 1
(0) noook, хмммм, даж не знаю *09, такой код работает:
Код 1C v 8.х
 Процедура ОбработкаПроведения(Отказ, Режим)
// добавим запись в регистр ТоварыНаСкладах Приход
Движения.ТоварыНаСкладах.Записывать = Истина;
Движения.ТоварыНаСкладах.Очистить();
Для Каждого ТекСтрокаТовары Из Товары Цикл
Движение = Движения.ТоварыНаСкладах.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Количество = ТекСтрокаТовары.Количество;
КонецЦикла;
КонецПроцедуры
noook
15.08.2012 09:38Ответ № 2
Вопрос закрыт!
Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.