helpf.pro
Регистрация

v8.2 УП: Заполнение табличного поля

bless18
21.08.2012 10:57Прочитано: 2822
Добрый день!
В табличной части документа при изменении одного поля, в другое автоматически должны попадать данные согласно измененному полю.
В 1С 8.2 создаю конфигурацию мини-библиотека. Имеется документ Выдача с табличной частью ВыдачаКниг. Ее поля:
НаименованиеКниги (Ссылка на справочник)
Расположение (Ссылка на справочник)
Количество
ДатаВыдачи
ДатаВозврата

При выборе Наименования книги в поле Расположение должны попасть данные из Регистра сведений ХранилищеКниг.
Пишу функцию на сервере и вызываю ее на клиенте:

Код 1C v 8.2 УП
 &НаСервере
Функция ПрочитатьХранениеКниги (Книга)
СтруктураОтбора = Новый Структура;
СтруктураОтбора.Вставить("Книги",Книга);

СтруктураРесурсов = РегистрыСведений.ХранилищеКниг.СрезПоследних(, СтруктураОтбора);
Возврат СтруктураРесурсов.МестоХраненияКниг;
КонецФункции

&НаКлиенте
Процедура ВыдачаКнигНаименованиеКнигиПриИзменении(Элемент)
Стр = Элементы.ВыдачаКниг.ТекущиеДанные;
Стр.Расположение = ПрочитатьХранениеКниги(Стр.НаименованиеКниги);
КонецПроцедуры

Программа выдает следующую ошибку:
{Документ.ВыдачаКниг.Форма.ФормаДокумента.Форма(8)}: Поле объекта не обнаружено (МестоХраненияКниг)
Возврат СтруктураРесурсов.МестоХраненияКниг;

МестоХраненияКниг - это ресурс регистра сведений. А СтруктураРесурсов возвращает тип Таблица Значений.
Yandex
Возможно, вас также заинтересует
Реклама на портале
bless18
21.08.2012 11:00Ответ № 1
Проблема решилась )
Нужно вместо СрезаПоследних использовать ПолучитьПоследнее. И выполнять Процедуру &НаКлиенте с последующим вызовом Сервера
Код 1C v 8.2 УП
 
&НаКлиенте
Процедура ВыдачаКнигНаименованиеКнигиПриИзменении(Элемент)
Стр = Элементы.ВыдачаКниг.ТекущиеДанные;
Стр.Расположение = ПрочитатьХранениеКниги(Стр.НаименованиеКниги);
КонецПроцедуры


&НаСервере
Функция ПрочитатьХранениеКниги (Книга)
СтруктураОтбора = Новый Структура;
СтруктураОтбора.Вставить("Книги",Книга);

СтруктураРесурсов = РегистрыСведений.ХранилищеКниг.ПолучитьПоследнее(, СтруктураОтбора);
Возврат СтруктураРесурсов.МестоХраненияКниг;
КонецФункции

bless18
21.08.2012 11:59Ответ № 2
Вопрос закрыт!
E_Migachev
21.08.2012 12:26Ответ № 3
(0) bless18, все верно у тебя получается таблица значений, если уверен что в ней 1 запись то делай так:
Код 1C v 8.2 УП
 Возврат СтруктураРесурсов[0].МестоХраненияКниг;   
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.