helpf.pro
Регистрация

Проверка на сущестование документа

bless18
17.06.2010 19:23Прочитано: 1369
Здравствуйте!
Помогите пожалуйста со следующей вещью:
имеется обработка, поле заполнения ТЧ которой, данные записываются в документ.
Необходимо сделать проверку на сущестовование такого документа, при этом, если документ не проведен, он считается существующим
Делаю выборку данных из документа, в который записваю данные и выполняю проверку на существование этого документа таким образом:
Код 1C v 8.х
 
НовыйДокумент = Документы.РаспределениеЗадачи.СоздатьДокумент();
НовыйДокумент.Дата = ТекущаяДата();
НовыйДокумент.УстановитьНовыйНомер();
НовыйДокумент.Отдел = ОбработкаОбъект.Отдел;
НовыйДокумент.ПолучательЗадачи = ОбработкаОбъект.ПолучательЗадачи;
НовыйДокумент.ИмяПользователя = ОбработкаОбъект.Пользователь;
Запрос=новый Запрос;
Запрос.Текст="ВЫБРАТЬ
| РаспределениеЗадачиРаспределениеЗадачиСотрудникам.Задача,
| РаспределениеЗадачиРаспределениеЗадачиСотрудникам.Ссылка.Дата
|ИЗ
| Документ.РаспределениеЗадачи.РаспределениеЗадачиСотрудникам КАК РаспределениеЗадачиРаспределениеЗадачиСотрудникам
|ГДЕ
| РаспределениеЗадачиРаспределениеЗадачиСотрудникам.Ссылка.Дата = &Дата";
Запрос.УстановитьПараметр("Дата", КонецДня(ЭтотОбъект.Дата));
Результат=Запрос.Выполнить().Выгрузить();

ЕСТЬДОК=Ложь;
Для Каждого СтрокаРаспределениеЗадачиСотрудникам Из Результат Цикл
СтрокаТабличнойЧасти=ОбработкаОбъект.РаспределениеЗадачи.Выгрузить();
Если СтрокаТабличнойЧасти.Задача=СтрокаРаспределениеЗадачиСотрудникам.Задача
Тогда
ЕСТЬДОК=Истина;
КонецЕсли;
КонецЦикла;
Если ЕСТЬДОК Тогда
Предупреждение ("Такой документ уже существует");
Иначе
Для Каждого СтрокаТЗ Из ЭтотОбъект.РаспределениеЗадачи Цикл
НовыйДокумент.РаспределениеЗадачиСотрудникам.Загрузить(ОбработкаОбъект.РаспределениеЗадачи.Выгрузить());
НовыйДокумент.Записать(РежимЗаписиДокумента.Проведение);
СозданныйДокумент = НовыйДокумент.Ссылка;
КонецЦикла;
КонецЕсли;
Предупреждение("Данные успешно записаны в документ Распределение задачи");


Почему-то программа не заходит в условие:
Код 1C v 8.х
 
Для Каждого СтрокаРаспределениеЗадачиСотрудникам Из Результат Цикл
СтрокаТабличнойЧасти=ОбработкаОбъект.РаспределениеЗадачи.Выгрузить();
Если СтрокаТабличнойЧасти.Задача=СтрокаРаспределениеЗадачиСотрудникам.Задача
Тогда
ЕСТЬДОК=Истина;
КонецЕсли;

А у СтрокаРаспределениеЗадачиСотрудникам значение неопеределено..
Как это исправить?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
18.06.2010 10:42Ответ № 1
(0) bless18, проблема однозначно в запросе! а точнее:
| РаспределениеЗадачиРаспределениеЗадачиСотрудникам.Ссылка.Дата = &Дата";
Запрос.УстановитьПараметр("Дата", КонецДня(ЭтотОбъект.Дата));
похоже нет документа с датойКонецДня(ЭтотОбъект.Дата)
bless18
19.06.2010 15:22Ответ № 2
Да, действительно!
Исправила, спасибо за помощь!
bless18
19.06.2010 15:22Ответ № 3
Вопрос закрыт!
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.