helpf.pro
Регистрация

v8.2 УП: Параметры в запросе

bless18
22.08.2012 10:45Прочитано: 1100
Здравствуйте!
Есть два документа: ВыдачаКниг и ВозвратКниг. У них имеется реквизит ТЧ ДатаВозврата. При проведении документа ВозвратКниг необходимо, если ДатаВозврата документа ВозвратКниг меньше ДатаВозврата документа ВыдачаКниг, присвоить значение ДатыВозврата документа ВыдачаКниг
Осуществляю это запросом с параметрами "Книга" и "Читатель", чтобы выборка была по тому читателю и книге, который ее возвращает. Но проблема в том, что несмотря на параметры из Регистра сведений выбирается документ, не связанный с конкретным читателем, а имеющий датуВозврата больше, чем у документа ВозвратКниг..Не могу понять, что сделано некорректно в запросе
*01
Код 1C v 8.2 УП
 
Движения.УчетКнигУЧитателей.Записывать = Истина;
Для Каждого ТекСтрокаВозвратКниг Из ВозвратКниг Цикл
Движение = Движения.УчетКнигУЧитателей.Добавить();
Движение.Период = Дата;
Движение.Книги = ТекСтрокаВозвратКниг.НаименованиеКниги;
Движение.Читатель = Читатель;
Движение.ДатаВозврата = ТекСтрокаВозвратКниг.ДатаВозврата;
Движение.СтатусВозврата = Истина;

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Книга", ТекСтрокаВозвратКниг.НаименованиеКниги);
Запрос.УстановитьПараметр("Читатель", Читатель);
Запрос.Текст = "ВЫБРАТЬ
| УчетКнигУЧитателей.ДатаВозврата,
| УчетКнигУЧитателей.Читатель,
| УчетКнигУЧитателей.Книги
|ИЗ
| РегистрСведений.УчетКнигУЧитателей КАК УчетКнигУЧитателей
|ГДЕ
| УчетКнигУЧитателей.Книги = &Книга
| И УчетКнигУЧитателей.Читатель = &Читатель";
Результат = Запрос.Выполнить().Выгрузить();
Для Каждого ТекСтрока Из Результат Цикл
Если Движение.ДатаВозврата < ТекСтрока.ДатаВозврата Тогда
Движение.ДатаВозврата = ТекСтрока.ДатаВозврата;
КонецЕсли;
КонецЦикла;
КонецЦикла;

Yandex
Возможно, вас также заинтересует
Реклама на портале
bless18
22.08.2012 10:53Ответ № 1
ТекСтрокаДатаВозврата у конкретного читателя = 25.08.2012. При первом прохождении цикла значение у ТекСтрокаДатаВозврата = 25.08.2012, а на второй итерации ТекСтрокаДатаВозврата дает значение 31.08.2012
E_Migachev
22.08.2012 22:19Ответ № 2
хмммм... тут надо смотреть на конфе, так сложно
bless18
24.08.2012 09:58Ответ № 3
После перепроведения документов все заработало. Спасибо!
bless18
24.08.2012 09:58Ответ № 4
Вопрос закрыт!
Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.