helpf.pro
Регистрация

v8: отправка e-mail из 1с

Ermak
13.09.2012 12:55Прочитано: 1299
Добрый день!
Я хочу с помощью 1С отправить по e-mail 5 документов .xml с папки, нужно чтобы один раз указал путь к папки, нажал кнопку отправить и документы (формата xml), которые имеются в папки все отправили, не могу понять что у меня не так!

В обработки есть два переключателя Файл и Каталог, Поле ввода ПутьККаталогу

Код 1C v 8.х
 Процедура ВыбратьФайл()

ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ДиалогВыбораФайла.Заголовок = "Выберите файл для загрузки";
ДиалогВыбораФайла.ПредварительныйПросмотр = Ложь;
ДиалогВыбораФайла.Каталог = ПутьКФайлу;
ДиалогВыбораФайла.Фильтр = "Файл выгрузки (*.xml)|*.xml";

Если ДиалогВыбораФайла.Выбрать() Тогда

ПутьКФайлу = ДиалогВыбораФайла.ПолноеИмяФайла;

КонецЕсли;

КонецПроцедуры // ВыбратьФайл()


Код 1C v 8.х
 Процедура ВыбратьКаталог()

ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
ДиалогВыбораФайла.Заголовок = "Выберите каталог для загрузки";
ДиалогВыбораФайла.ПредварительныйПросмотр = Ложь;
ДиалогВыбораФайла.Каталог = ПутьККаталогу;
ДиалогВыбораФайла.Фильтр = "Файл выгрузки (*.xml)|*.xml";

Если ДиалогВыбораФайла.Выбрать() Тогда

ПутьККаталогу = ДиалогВыбораФайла.Каталог;

КонецЕсли;

КонецПроцедуры // ВыбратьКаталог()


Что тут не так?
Код 1C v 8.х
  
//При необходимости делаем вложение с файлом

Если ЗагрузкаВозможна() Тогда
Возврат;
КонецЕсли;

Если Файл = "Файл" Тогда
Сообщение.Вложения.Добавить(ПутьКФайлу);
Иначе
НайденныеФайлы = НайтиФайлы(ПутьККаталогу, "*.xml");
Для каждого ТекущийФайл Из НайденныеФайлы Цикл
ЗагрузитьФайлВыгрузки(ТекущийФайл.ПолноеИмя);
КонецЦикла;
КонецЕсли;
Yandex
Возможно, вас также заинтересует
Реклама на портале
Ermak
13.09.2012 13:54Ответ № 1
Вопрос закрыт!
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.