helpf.pro
Регистрация

v8: Автоподстановка расчетного счета контрагента

bless18
24.09.2012 10:11Прочитано: 1891
Добрый день!
При выборе контрагента в поле счет автоматически должен подставиться счет контрагента
Пишу:
Код 1C v 8.2 УП
 
ЭлементыФормы.СчетКонтрагента.ВыборПоВладельцу=Контрагент;

СчетКонтрагента = Контрагент.ОсновнойБанковскийСчет;


Счет не выводится. Значение СчетКонтрагента при выполнении программы = Справочник.Ссылка.
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
24.09.2012 11:36Ответ № 1
(0) bless18, ты в каком событии это пишешь?
bless18
24.09.2012 12:25Ответ № 2
В Событии КонтрагентПриИзменении(Элемент)
E_Migachev
24.09.2012 12:38Ответ № 3
(2) bless18, тогда нужно писать как-то так:
Код 1C v 8.х
 СтрокаТабличнойЧасти = ЭлементыФормы.ИмяТабЧасти.ТекущиеДанные;
СтрокаТабличнойЧасти.СчетКонтрагента = Контрагент.ОсновнойБанковскийСчет;
bless18
24.09.2012 12:58Ответ № 4
Поле Контрагент не является элементом ТЧ. Это объект формы
bless18
24.09.2012 12:59Ответ № 5
Поле расположено на Панели
Bell
24.09.2012 13:44Ответ № 6
Код 1C v 8.х
 Процедура ЗаполнениеКонтрагентДоговорРасчетныеСчета(Контрагент,Договор,РасчетныеСчета) Экспорт
Если ЗначениеЗаполнено(Контрагент) Тогда
Договор = Контрагент.Договор;
РасчетныеСчета=Контрагент.РасчетныеСчета;
Иначе
Договор = Справочники.Контрагенты_Договора.ПустаяСсылка();
РасчетныеСчета=Справочники.Контрагенты_РасчетныеСчета.ПустаяСсылка();
КонецЕсли;
КонецПроцедуры

Изменено 24.09.12 13:45:46
bless18
24.09.2012 14:25Ответ № 7
Спасибо за Ваш пример..
Последовала ему. В поле СчетКонтрагента все еще значение СправочникСсылка.БанковскиеСчета

Код 1C v 8.2 УП
 
Процедура ЗаполнениеКонтрагентДоговорРасчетныеСчета(Контрагент,СчетКонтрагента) Экспорт
Если ЗначениеЗаполнено(Контрагент) Тогда
СчетКонтрагента=Контрагент.ОсновнойБанковскийСчет;
Иначе
СчетКонтрагента=Справочники.БанковскиеСчета.ПустаяСсылка();
КонецЕсли;
КонецПроцедуры
Процедура КонтрагентПриИзменении(Элемент)

// проставим основной договор контрагента
ПриИзмененииКонтрагента();

ЗаполнениеКонтрагентДоговорРасчетныеСчета(Контрагент, СчетКонтрагента);

ПриИзмененииДоговора();

УстановитьФокус();

КонецПроцедуры // КонтрагентПриИзменении()

bless18
24.09.2012 15:20Ответ № 8
И, соответственно, ничего не выводится
E_Migachev
24.09.2012 15:21Ответ № 9
(4) bless18, я это понял
код указанный в (3) должен работать
bless18
24.09.2012 15:54Ответ № 10
Все заработало! Спасибо большое )
bless18
24.09.2012 15:54Ответ № 11
Вопрос закрыт!
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.