helpf.pro
Регистрация

?: При открытии документа из справочника

LUDA
26.09.2012 07:35Прочитано: 1178
Как программно, при открытии документа из справочника сотрудники, установить курсор в нужную строку???
Yandex
Возможно, вас также заинтересует
Реклама на портале
theelectric
26.09.2012 09:04Ответ № 1
(0) LUDA, а если чуть поточнее - что именно надо активировать: какой-то реквизит или строку табчасти?
theelectric
26.09.2012 09:04Ответ № 2
(0) LUDA, а если чуть поточнее - что именно надо активировать: какой-то реквизит или строку табчасти?
LUDA
26.09.2012 09:13Ответ № 3
Строку табличной части документа Табель учета рбочего времени
theelectric
26.09.2012 09:34Ответ № 4
(3) LUDA, ну тогда, я так думаю, тебе надо что-то типа такого:

Код 1C v 8.2 УП
 Для Каждого СтрокаТабЧасти Из ОтработанноеВремя Цикл
Если СтрокаТабЧасти.Сотрудник = СотрудникДляПоиска Тогда
ЭлементыФормы.ТабличнаяЧасть1.ТекущаяСтрока = СтрокаТабЧасти;
Прервать;
КонецЕсли;
КонецЦикла;
theelectric
26.09.2012 09:35Ответ № 5
(3) LUDA, малость не то написал - вот так:

Код 1C v 8.2 УП
 
Для Каждого СтрокаТабЧасти Из ОтработанноеВремя Цикл
Если СтрокаТабЧасти.Сотрудник = СотрудникДляПоиска Тогда
ЭлементыФормы.ОтработанноеВремя.ТекущаяСтрока = СтрокаТабЧасти;
Прервать;
КонецЕсли;
КонецЦикла;
LUDA
26.09.2012 09:48Ответ № 6
Не получается. У меня открыт элемент справочника сотрудники(допустим Сидоров), в справончике есть закладка с документами проведенного табеля за каждый месяц(которые относятся к нашему сотруднику Сидорову). Мне надо при открытии документа сразу встать на Сидорова. Как это сделать программно???
theelectric
26.09.2012 10:26Ответ № 7
Что 1С пишет в ошибке?
theelectric
26.09.2012 10:27Ответ № 8
В примере тебе ж надо еще заменить СотрудникДляПоиска на твоего сотрудника!
theelectric
26.09.2012 10:37Ответ № 9
А вот как "запомнить сотрудника", из которого открыла документ, я не знаю... Мне кажется такого не овзможно сделать, по крайней мере, в свойствах ссылки и объекта подоюных полей нет!
LUDA
27.09.2012 02:36Ответ № 10
Ошибку не выдает, просто открывает без изменений. По отладке он находит, просто как спозиционировать на нужно сотруднике при открытии.
theelectric
27.09.2012 08:59Ответ № 11
(10) LUDA, если честно, я немного не пойму - что именно тебя не получается... *09

Вот ссылка - ТестОбработка
- там простенькая обработка с кодом, который написал чуть выше. Там указываешь документ табеля и сотрудника, на котором бы ты хотела, чтобы обработка спозиционировала.

Тебе надо указать в процедуре ПриОткрытии документа табеля и вставить примерно такой код:

Код 1C v 8.2 УП
 
Процедура ПриОткрытии(Сотрудник)

Если ЗначениеЗаполнено(Сотрудник) Тогда

Для Каждого СтрокаТабЧасти Из ОтработанноеВремя Цикл
Если СтрокаТабЧасти.Сотрудник = Сотрудник Тогда
ЭлементыФормы.ОтработанноеВремя.ТекущаяСтрока = СтрокаТабЧасти;
Прервать;
КонецЕсли;
КонецЦикла;

КонецЕсли;

КонецПроцедуры


P.S. Надеюсь правильно тебя понял...
theelectric
27.09.2012 09:44Ответ № 12
Пардон, кинул не ту обработку - вот ЭТУ
надо!
LUDA
28.09.2012 07:00Ответ № 13
Спасибо. Спасибо Спасибо Спасибо Получилось!!!
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.