helpf.pro
Регистрация

v8: Проверка на существование файла

bless18
29.10.2012 16:59Прочитано: 1585
Добрый день!
Помещаю файл в хранилище значений. В процедуре ПриЗаписи пишу следующую конструкцию
Код 1C v 8.2 УП
 

Процедура ПередЗаписью(Отказ, Замещение)

Для каждого Запись Из ЭтотОбъект Цикл
ВнешнийФайл = Запись.Хранилище.Получить();//Двоичные данные файла

ИмяВременногоФайла = ПолучитьИмяВременногоФайла(Запись.Расширение);

Файл = Новый Файл(ИмяВременногоФайла);


Если Файл.Существует() Тогда
Если ВнешнийФайл.Размер()> 0 Тогда
Запись.ЕстьФайл = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;

КонецПроцедуры


Строчка Если Файл.Существует() всегда возвращает Ложь, даже, если файл есть..Где ошибка, не пойму.
Yandex
Возможно, вас также заинтересует
Реклама на портале
bless18
29.10.2012 17:01Ответ № 1
ИмяВременногоФайла возвращает значение временного файла в базе
ВнешнийФайл = Запись.Хранилище.Получить() почему-то неопределено
E_Migachev
29.10.2012 17:12Ответ № 2
(1) bless18, ИмяВременногоФайла - чему равно?
bless18
29.10.2012 17:17Ответ № 3
Оно равно
C:\Documents and Settings\aselfimova\Local Settings\Temp\v8_275_17.docx
bless18
29.10.2012 17:21Ответ № 4
Его и впрямь нет в этом каталоге..
Как же мне правильно проверку написать на наличие файла?
В регистр сведений добавляются данные. К этим данным могут быть прикреплены файлы, а могут и не быть. Нужно рассмотреть условие, когда файл существует, то есть прикреплен
E_Migachev
29.10.2012 17:21Ответ № 5
(3) bless18, Данный метод предназначен для получения такого имени. При выполнении метода файл не создается. - поэтому файл и не существует!
bless18
29.10.2012 17:30Ответ № 6
Файл уже создан. Он присутствует в Хранилище. В Модуле записей нужно проверить наличие этого файла.
E_Migachev
29.10.2012 17:50Ответ № 7
(6) bless18, в твоем примере нет кода записи данных в файл, соответственно он еще не создан
bless18
30.10.2012 13:45Ответ № 8
А, поняла.
Спасибо!
bless18
30.10.2012 14:24Ответ № 9
Вопрос закрыт!
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.