helpf.pro
Регистрация

v8: Работа с индикаторами

Ermak
30.10.2012 13:07Прочитано: 2429
Подскажите как использовать индикатор

Код 1C v 8.х
 //проверим что файл существует
ФайлНаДиске = Новый Файл(Файл);
Если Не ФайлНаДиске.Существует() Тогда
Предупреждение("Файл не найден!");
Возврат;
КонецЕсли;

Ex = ПолучитьТаблицуExcel(Файл);

СтруктураДанных = Новый Структура("Колонка1, Колонка2, Колонка3, Колонка4, Колонка5, Колонка6");

НС = 1;
Пока Истина Цикл
СтруктураДанных.Колонка1 = СокрЛП(Ex.Cells(НС,1).Value);
СтруктураДанных.Колонка2 = СокрЛП(Ex.Cells(НС,2).Value);
СтруктураДанных.Колонка3 = СокрЛП(Ex.Cells(НС,3).Value);
СтруктураДанных.Колонка4 = СокрЛП(Ex.Cells(НС,4).Value);
СтруктураДанных.Колонка5 = СокрЛП(Ex.Cells(НС,5).Value);
СтруктураДанных.Колонка6 = СокрЛП(Ex.Cells(НС,6).Value);

Если СтруктураДанных.Колонка1 = "" Тогда
Прервать;
КонецЕсли;

#Если Клиент Тогда
Состояние("Номер обработанной строки: " + НС);
#КонецЕсли

НоваяСтрока = Данные.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока, СтруктураДанных);


НС = НС + 1;
КонецЦикла;



Ex.Quit();
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
30.10.2012 13:40Ответ № 1
(0) Ermak, Индикатор выполнения обработки результата запроса
в твоем случае будет так неизвестно кол-во всего!?
а так, перед циклом добавляй:
Код 1C v 8.х
 Индикатор = ЭлементыФормы.ИндикаторПеребора; 
Индикатор.МаксимальноеЗначение = ВсегоКоличество; // <- ВОТ ТУТ НАДО УКАЗАТЬ КОЛИЧЕСТВО
Индикатор.Значение = 0;
Пока Истина Цикл
Индикатор.Значение = Индикатор.Значение + 1;

// ....
КонецЦикла;
Ermak
30.10.2012 14:09Ответ № 2
Спасибо
Ermak
30.10.2012 14:09Ответ № 3
Вопрос закрыт!
Ermak
30.10.2012 14:26Ответ № 4
т.е в моем случае не получится?
Ermak
30.10.2012 14:29Ответ № 5
Почему ошибка?

{Форма.Форма.Форма(129)}: Значение не является значением объектного типа (МаксимальноеЗначение)
Индикатор.МаксимальноеЗначение = ТП.Количество(); // <- ВОТ ТУТ НАДО УКАЗАТЬ КОЛИЧЕСТВО


Код 1C v 8.х
 Индикатор = ЭлементыФормы.Индикатор; 
Индикатор.МаксимальноеЗначение = ТП.Количество();
Индикатор.Значение = 0;

Для Каждого Строчка Из ТП Цикл
Индикатор.Значение = Индикатор.Значение + 1;
НовыйЭлемент = Справочники.Адреса.СоздатьЭлемент();
НовыйЭлемент.Район = Строчка.Колонка1;
НовыйЭлемент.РУ = Строчка.Колонка2;
НовыйЭлемент.Наименование = Строчка.Колонка3;
НовыйЭлемент.Дом = Строчка.Колонка4;
НовыйЭлемент.Емкости = Строчка.Колонка5;
НовыйЭлемент.Головки = Строчка.Колонка6;
НовыйЭлемент.Записать();

КонецЦикла;
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.