helpf.pro
Регистрация

v8: Как найти контрагента по родителю

gatalik
04.11.2012 01:44Прочитано: 1427
Код 1C v 8.2 УП
 &НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
Если Объект.Родитель.Пустая() Тогда
Объект.ЮрЛицо=Ложь;
ИначеЕсли Объект.Родитель="Поставщики" Тогда
Объект.ЮрЛицо=Истина;
Иначе
Объект.ЮрЛицо=Ложь;
КонецЕсли;
КонецПроцедуры

есть такой фрагмент кода, когда смотрю через отладчик на таблицу значений, для родителя показывает значение Поставщики но Объект.Родитель="Поставщики" почему то равно ложь, а должна быть истина, подскажите где здесь ошибка, проверял по другим реквизитам, наприер по коду Объект.код = 111 возвращало истину а с родитель вообще ни в какую не срабатывает
Изменено 04.11.12 17:59:58
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
04.11.2012 17:59Ответ № 1
(0) gatalik,
Код 1C v 8.2 УП
 СкорЛП(Объект.Родитель.Наименование)="Поставщики"   
gatalik
06.11.2012 20:58Ответ № 2
{Справочник.Контрагенты.Форма.ФормаЭлемента.Форма(8)}: Поле объекта не обнаружено (Наименование)
ИначеЕсли СокрЛП(Объект.Родитель.Наименование)="Поставщики" Тогда
С наименованием уже пытался.
gatalik
06.11.2012 21:02Ответ № 3
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

Если Объект.Родитель.Пустая() Тогда
Объект.ЮрЛицо=Ложь;
ИначеЕсли СокрЛП(Объект.Родитель)="Поставщики" Тогда
Объект.ЮрЛицо=Истина;
Иначе
Объект.ЮрЛицо=Ложь;
КонецЕсли;
КонецПроцедуры
Наименование не надо а за СокрЛП спасибо;)
ivan232
16.11.2012 08:53Ответ № 4
Вопрос закрыт!
E_Migachev
08.06.2014 14:34Ответ № 5
Код 1C v 8.х
 // Получить ссылку на группу, в которой будет находиться новый элемент. 
Родитель = Справочники.Банки.НайтиПоКоду("000000001"); 

НовыйЭлемент.Наименование = "АКБ"; 
НовыйЭлемент.Код = "000000011"; 
НовыйЭлемент.Родитель = Родитель;
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.