helpf.pro
Регистрация

v8: Открытие регистра сведений с отбором по данным отчета

bless18
12.11.2012 14:44Прочитано: 4880
Здравствуйте!!!!

Есть отчет, для которого нужно добавить свою расшифровку. Расшифровка должна открыть форму списка регистра сведений с отбором по измерениям:

ФизЛицо - Справочник.Ссылка
Событие - Строка
Дата

Формируется отчет, в котором присутствуют эти поля.

В процедуре ОбработкаРасшифровки, опираясь на материалы Вашего сайта, написала следующее:

Код 1C v 8.2 УП
 
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
Перем ВыполненноеДействие;

СтандартнаяОбработка=Ложь;

ОбработкаРасшифровки=Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки,Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));

ДополнительныеДействия=Новый СписокЗначений;

ДополнительныеДействия.Добавить("ОбъяснительныеСотрудника","Объяснительные сотрудника");



Настройки=ОбработкаРасшифровки.Выполнить(Расшифровка,ВыполненноеДействие,,ДополнительныеДействия);

Если Настройки<>Неопределено Тогда

КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);

ЭлементыФормы.Результат.Очистить();

СкомпоноватьРезультат(ЭлементыФормы.Результат,ДанныеРасшифровки);

Иначе

Если ВыполненноеДействие="ОбъяснительныеСотрудника" Тогда

// Выполнить процедуру открытия формы списка с отбором

КонецЕсли;

КонецЕсли;


КонецПроцедуры



Не могу открыть форму списка регистра сведений с отбором, используя данные строки отчета.
Может, кто знает, как обратиться к ячейке табличного документа.
Помогите, пожалуйста .


*09
Yandex
Возможно, вас также заинтересует
Реклама на портале
bless18
12.11.2012 15:04Ответ № 1
Отбор по регистру будет такой:
Код 1C v 8.2 УП
 
// Выполнить процедуру открытия формы списка с отбором

Отбор = Новый Структура;
Отбор.Вставить("ФизЛицо", );

Выборка = РегистрыСведений.БИТ_СКУД_Объяснительные.Выбрать(Отбор);
Выборка.Следующий();

Объяснительные = Выборка.ПолучитьМенеджерЗаписи().ПолучитьФорму("ФормаСписка");
Объяснительные.Открыть();

// Но в Отбор.Вставить("ФизЛицо", ); необходимо обращение к ячейке табличного документа..
bless18
13.11.2012 10:12Ответ № 2
Вопрос закрыт!
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.