helpf.pro
Регистрация

v7: Код не уникален

cliiic
13.11.2012 15:24Прочитано: 7282
Добрый День! Подскажите пожалуйста
У меня программа 1с 7.7 торговля и склад , во общем при создание нового контрагента вылазит ошибка ошибка "код не уникален"
перенумерацию справочника контрагенты делал обработкой(и не одной), причем всего и даже с перефериксом вначале типа в0001633
все равно при создание нового контрагента программа ругается "код не уникален" и все

что можно еще попробовать?
Yandex
Возможно, вас также заинтересует
Реклама на портале
Mokey
13.11.2012 15:32Ответ № 1
1. попробовать руками забить какой-нибудь следующий код.
2. посмотреть, какой код выдаётся при создании нового элемента, сдаётся мне, он последний из возможных, тогда увеличить разрядность кода
cliiic
13.11.2012 16:02Ответ № 2
Руками тоже пробывал забивать на один или несколько шагов больше, не помогает
при создание нового Элемента код 00001633
ad82117
13.11.2012 16:45Ответ № 3
значит у тебя есть уже "00001633";
смотри внимательнее и видимо твоя обработка (и не одна) по перенумерации как-то не работает
вот самый примитивный пример, который работает на "ура"!
Код 1C v 7.x
 Процедура Сформировать()
Спр=Создатьобъект("Справочник.Номенклатура");
Счет=1;
Спр.ВыбратьЭлементы(0);
Пока Спр.ПолучитьЭлемент()=1 Цикл
Если счет<10 Тогда
Спр.Код="А000000"+Счет;
Спр.Записать();
ИначеЕсли счет<100 Тогда
Спр.Код="А00000"+Счет;
Спр.Записать();
ИначеЕсли счет<1000 Тогда
Спр.Код="А0000"+Счет;
Спр.Записать();
ИначеЕсли счет<10000 Тогда
Спр.Код="А000"+Счет;
Спр.Записать();
ИначеЕсли счет<100000 Тогда
Спр.Код="А00"+Счет;
Спр.Записать();
ИначеЕсли счет<1000000 Тогда
Спр.Код="А0"+Счет;
Спр.Записать();
ИначеЕсли счет<10000000 Тогда
Спр.Код="А"+Счет;
Спр.Записать();
КонецЕсли;
Счет=Счет+1;
Сообщить(Счет);
КонецЦикла;
КонецПроцедуры
Mokey
13.11.2012 17:35Ответ № 4
Отладчиком посмотреть, какой код проверяется на уникальность, возможно, перед записью или при записи срабатывает автонумерация.
Если база SQL, то перезапустить сервер после перенумерации, чтобы сбросить все кэши.
cliiic
14.11.2012 08:20Ответ № 5
а как запустить эту обработку? в отладчике?
если не трудно опишите как?
Пожалуйста=))
ad82117
14.11.2012 09:57Ответ № 6
хм... как запустить спрашиваешь...
эх, молодёжь! по 7.7 столько инфы в инете, а сколько ещё будет))
итак
01. выгоняешь всех из базы.
02. делаешь архив либо физическим архивом папки либо через конфигуратор
- меню "Администрирование" - "Сохранить данные" (файловый вариант) либо "Выгрузить данные" (SQL). для файлового варианта и то и то хорошо, но не о вариантах сохранения щас речь, хотя тоже важная тема
03. в конфигураторе Меню "Файл" - "новый" - "внешний отчёт (обработка)"
04. открывается конструктор обработки - внизу закладки. тебе нужна "Модуль".
05. удаляешь те две строки кода и вставляешь то, что я прислал
06. вместо "Справочник.Номенклатура" пишешь "Справочник.Контрагенты"
07. сохраняешь всё это
08. через Ф11 из Конфигуратора заходишь в Предприятие
09. выбираешь обрабулину.
10. запускаешь
11. оргазмируешь
cliiic
14.11.2012 10:19Ответ № 7
Все сделал как было сказано справочник перенумерован, все равно создаешь контрагента код не уникален =(
cliiic
14.11.2012 10:43Ответ № 8
можно ли что-нибудь еще попробовать сделать?
ad82117
14.11.2012 12:33Ответ № 9
архив давай
cliiic
14.11.2012 13:27Ответ № 10
http://files.mail.ru/G1W2S3
ad82117
14.11.2012 15:44Ответ № 11
у тебя не справочник "Контрагенты" тупит, а справочник "Договоры"
зайди меню Операции - справочники - Договоры взаиморасчетов;
откроется справочник, т.к. он подчинён Контрагентам тебе нужно нажать на 4 кнопочку справа на панельке (где ввод новой строки). появятся все договора - сделай сортировку по коду ("ctrl+1") и иди в самый низ. увидишь хренотень. сделай аккуратно кода по счётчику (у меня последний нормальный 00026146). тебе соответственно нужно следующий поставить 00026147 и так далее. т.е. тебе нужно привести все кода к нормальному виду типа "00026146". всё.
cliiic
14.11.2012 16:31Ответ № 12
Спасибо Огромное Вы Мне Очень Помогли !!!!
cliiic
14.11.2012 16:31Ответ № 13
Вопрос закрыт!
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.