helpf.pro
Регистрация

v8: Работа с картинками

Bell
19.11.2012 11:46Прочитано: 1198
Здравствуйте
Управляемое прложение
Вопрос №1
Скажите можно избавиться от диалог при сохранении файл , что бы сразу открылось окно сохранения.
Код 1C v 8.х
 	ДанныеСохранения = ПолучитьНавигационнуюСсылку(Объект.Ссылка,"ПолеДанных");
ИмяСохранения = Объект.Наименование + Объект.ДанныеРасширение;
ПолучитьФайл(ДанныеСохранения,ИмяСохранения,Истина);

Вопрос №2
Не могу найти как отрыть файл для просмотра картинки по весь экран.
Yandex
Возможно, вас также заинтересует
Реклама на портале
DJ_Serega
19.11.2012 12:13Ответ № 1
(0) Bell,

Код

ПолучитьФайл (GetFile)
Синтаксис:

ПолучитьФайл(<Адрес>, <ИмяФайла>, <Интерактивно>)
Параметры:

<Адрес> (обязательный)

<ИмяФайла> (необязательный)


Тип: Булево.
Истина - режим, в котором пользователю показывается диалог, в котором он может выбрать действие с получаемым файлом: запустить его или сохранить по выбранному расположению.
В веб-клиенте параметр должен быть равен Истина. В противном случае будет сгенерировано сообщение об ошибке.
Значение по умолчанию: Истина


То есть нужно третий параметр как "ложь".
Bell
19.11.2012 13:07Ответ № 2
Если поставить ложь Тогда процедура не отрабатывает
Вот процедура сохранения файла как открыть файл из хранилица для просмотра
&НаКлиенте
Код 1C v 8.х
 Процедура СохранитьДанные(Команда)

Если НЕ ЗначениеЗаполнено(Объект.Ссылка) Тогда
Предупреждение(НСтр("ru = 'Элемент не записан !!!'"));
Возврат;
КонецЕсли;

ДанныеСохранения = ПолучитьНавигационнуюСсылку(Объект.Ссылка,"ПолеДанных");
ИмяСохранения = Объект.Наименование + Объект.ДанныеРасширение;
ПолучитьФайл(ДанныеСохранения,ИмяСохранения,Истина);

КонецПроцедуры


&НаСеревере
Процедура ОткрытьДанные(Команда) // На просмотр

// ????

КонецПроцедуры
DJ_Serega
18.12.2012 14:27Ответ № 3
(2) Bell, Так это в УП?
Bell
28.12.2012 13:58Ответ № 4
Вопрос закрыт!
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.