helpf.pro
Регистрация

v8: Перевод секунд в часы и минуты

Nessty
21.11.2012 16:40Прочитано: 7022
Добрый день!
Подскажите, пожалуйста, универсальный способ перевода секунд в часы и минуты. При этом округлять минуты до целых по правилу Окр15как20.
Спасибо!
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
22.11.2012 01:29Ответ № 1
(0) Nessty, вот несколько примеров:
Код 1C v 8.х
 Время = 10245;
Секунды = Время % 60;
Минуты = (Время-Секунды)/60;
Минуты = Минуты % 60;
Часы = (Время-Секунды-Минуты*60)/3600;


Код 1C v 8.х
 Секунд=7527; 
Часов=Цел(Секунд/3600);
СекОстМин= Секунд%3600;
Минут=Цел(СекОстМин/60);
Сек=СекОстМин%60;
Если Часов<10 Тогда
Часов="0"+СокрЛП(Часов);
Иначе
Часов=СокрЛП(Часов);
КонецЕсли;
Если Минут<10 Тогда
Минут="0"+СокрЛП(Минут);
Иначе
Минут=СокрЛП(Минут);
КонецЕсли;
Если Сек<10 Тогда
Сек="0"+СокрЛП(Сек);
Иначе
Сек=СокрЛП(Сек);
КонецЕсли;
Время=Часов+":"+Минут+":"+Сек;
Сообщить(""+Время);


Код 1C v 8.х
 Процедура  СекундыВМинуты(Секунды)
Минуты=0;
Сч=0;
Пока Секунды>59 Цикл
Сч=Сч+1;
Если сч=60 Тогда
минуты=минуты+1;
сч=0;
КонецЕсли;
Секунды=Секунды-1;
КонецЦикла;
Сообщить(минуты);
КонецПроцедуры
Nessty
22.11.2012 09:36Ответ № 2
(1) E_Migachev, благодарствую!
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.