helpf.pro
Регистрация

v8: Работа с картинками

Bell
22.01.2013 17:33Прочитано: 1618
Здравсвуйте
Т.к. нельзя вызвать штатный диалог просмотра (Во весь экран) картинки
сторонние программы просмотра уже сделал
Создал произвольную форму Разместил на ней ПОЛЕ КАРТИНКИ - ДанныеХЗ
Как вытянуть данные ХЗ-Хранилища значений и передать на форму
Создал процедуру
Процедура формы элемента.
Код 1C v 8.х
 Процедура РежимПросмотраФайла()

ФормаПросмотраФайла = ПолучитьФорму("ФормаПросмотраФайла");
ФормаПросмотраФайла.СсылкаНаОбъект = Владелец;
ФормаПросмотраФайла.Наименование = Наименование;
//ФормаПросмотраФайла.ДанныеХЗ.Картинка = ХЗ.Получить(); ??????
ФормаПросмотраФайла.Открыть();

КонецПроцедуры

Изменено 22.01.13 17:33:39
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
23.01.2013 16:13Ответ № 1
по идее так, если я тебя правильно понял:
Код 1C v 8.х
 ФормаПросмотраФайла.ПолеКартинки.Картинка = Картинка.Получить(); 
// где Картинка = хранилище значений с картинкой
Bell
24.01.2013 17:36Ответ № 2
ДА именно так
Поле картики это поле картинки на прозивольной форму
Картинка (у меня ХЗ) это хранилище значений
Пишет ошибку
{Справочник.ХранилищеИзображений.Форма.ФормаЭлемента.Форма(87)}: Поле объекта не обнаружено (ПолеКартинки)
ФормаПросмотраФайла.ПолеКартинки.Картинка = ХЗ.Получить();

Может напрямую нельзя передавить ? искла вроде ничего не нашел.
E_Migachev
24.01.2013 22:44Ответ № 3
попробуй как параметр передать!
Bell
28.01.2013 14:08Ответ № 4
Если кому то будет интересно Сделал так
В произвольной форме завел параметр СправочникОбъект - Тип справочникОбъект
процедура передачи параметров из формы
Код 1C v 8.х
 Процедура РежимПросмотраФайла()

ФормаПросмотраФайла = ПолучитьФорму("ФормаПросмотраФайла");
ФормаПросмотраФайла.СсылкаНаОбъект = Владелец;
ФормаПросмотраФайла.Наименование = Наименование;
ФормаПросмотраФайла.ДанныеХЗ = Новый ХранилищеЗначения(СправочникОбъект.ХЗ.Получить(), Новый СжатиеДанных);
ФормаПросмотраФайла.Открыть();

КонецПроцедуры

Процедура произвольной формы
Код 1C v 8.х
 Перем ДанныеХЗ Экспорт; 

Процедура ОтображениеИзображения() в процедуру ПРИ ОТКРЫТИИ()

Если ДанныеХЗ.Получить() = Неопределено Тогда
ЭлементыФормы.ПолеИзображения.Картинка = Новый Картинка();
Возврат;
КонецЕсли;

ЭлементыФормы.ПолеИзображения.Картинка = ДанныеХЗ.Получить();

КонецПроцедуры

Изменено 28.01.13 14:15:26
Bell
28.01.2013 14:09Ответ № 5
Вопрос закрыт!
Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.