helpf.pro
Регистрация
 0 
Распечатать

Табличное поле ~ Картинки в полях динамических списков

Отобразить в поле динамического списка картинку вместо стандартной галочки можно двумя способами.

Первый: для поля назначить картинку размером 32х16 пикселов, а в коде устанавливать параметр «ЗначениеКартинки» в истину или ложь, то в колонке будет отображена левая часть для значения «ложь» и правая – для значения «истина».
Код 1C v 8.х
 Если ТекДокумент.Проведен Тогда
ОформлениеСтроки.Ячейки.ЕстьПКО.ОтображатьКартинку = Истина;
ОформлениеСтроки.Ячейки.ЕстьПКО.Картинка = БиблиотекаКартинок.ВыполненоУспешно32;
КонецЕсли;


Второй вариант:
Код 1C v 8.х
 Для Каждого ТекСтрока Из ОформленияСтрок Цикл
Ссылка = ТекСтрока.ДанныеСтроки.Ссылка;
ТекСтрока.Ячейки.ЕстьПКО.ОтображатьКартинку = Ссылка.Проведен;
ТекСтрока.Ячейки.ЕстьПКО.Картинка = БиблиотекаКартинок.ВыполненоУспешно32;
КонецЦикла;

В отличие от предыдущего варианта, здесь мы отображаем или не отображаем произвольную картинку (в данном случае, размером 32х32). При этом нужно указывать свойство Картинка, иначе она не отображается (даже, если задать в редакторе формы).

Для картинок с индексом:
Выбираем шапку ячейки табличного поля или дерева. В свойствах оформления выбираем “Картинки строк”.
Выбираем файл с индексами картинок либо же конкретную картинку из коллекции.
В свойствах табличного поля создаем обработчик события “ПриВыводеСтроки”.
В него пишем(“Имя файла” меняем на название вашей ячейки):
Код 1C v 8.х
 Процедура ДополнительныеФайлыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
ОформлениеСтроки.Ячейки.ИмяФайла.ОтображатьКартинку = Истина;
//Если необходимо указать конкретную картинку из коллекции в файле по индексу тогда дописываем:
ОформлениеСтроки.Ячейки.ИмяФайла.ИндексКартинки = 2;
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7585
 0 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
HTML5 Canvas в 1С 8.3 или Google нам поможет 0
Добрался я для написания маленьких тестов для 1С в плане web графики. Версии 1С 8.2.61 и 8.3.3.641. Зайдем на http://www.w3schools.com/html/html5_canvas.asp и перенесем примеры в обработку 1С. Скачать обработку: Результаты не радуют. 1С в Intern
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.