helpf.pro
Регистрация
 +5 
Распечатать

Как обновить динамический список или реквизит на форме клиента?

Если вы, открыв форму справочника или документа, выполнили некоторое действие, код который должен изменить состояние данных в динамических списках или значение реквизита. Данные изменены, но в открытой форме осталось все как было, можно конечно закрыть форму и открыть снова - все обновится

НО если нужно обновить сразу в открытой форме, то используйте код:

Код 1C v 8.3
  &НаКлиенте
Процедура ОбработатьВыборФайла(Результат, Адрес, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт
Если Не Результат Тогда
 Возврат; 
КонецЕсли;
// Много кода обработки
//...
//...
//...


// ОБНОВИМ динамический список файлы
Элементы.Файлы.Обновить();

// для обновления Реквизитов
ЭтаФорма.Прочитать();

// Обновление данных
ЭтаФорма.ОбновитьОтображениеДанных();

КонецПроцедуры

Обновить()Обновляет данные в таблице.

Прочитать()Обновляет объект управляемой формы.

ОбновитьОтображениеДанных()В принудительном порядке обновляет содержание элементов управления. Полезен при изменении значений реквизитов формы вне формы, в тот момент, когда форма отображается на экране.

Разместил:   Версии: | 8.2 УП | 8.3 |  Дата:   Прочитано: 24964
 +5 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 12
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 42
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 9
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Посмотреть все результаты поиска похожих
Комментарии
all4cf
25.08.2017 20:20Комментарий: 1
all4cf

Рабочий пример использования:

Код 1C v 8.3
 &НаСервере
Процедура ОтметитьЧтоЗабралиНаСервере(масСсылок)
Для Каждого стр из масСсылок Цикл 
текОбъект = стр.Значение.ПолучитьОбъект();
текОбъект.Забрали=Истина;
текОбъект.ЗабралиДата=ТекущаяДата();
текОбъект.ЗабралиПользователь=ПараметрыСеанса.ТекущийПользователь;
текОбъект.Записать();
КонецЦикла
КонецПроцедуры

&НаКлиенте
Процедура ОтметитьЧтоЗабрали(Команда)
масСсылок = Новый СписокЗначений;
Для Каждого стр из Элементы.СписокРеализацииТоваровУслуг.ВыделенныеСтроки Цикл 
масСсылок.Добавить(стр);
КонецЦикла;
ОтметитьЧтоЗабралиНаСервере(масСсылок);
ПоказатьОповещениеПользователя("Реализаций забрали", ,"Выполнено!", БиблиотекаКартинок.ДоставкаКолонкаДоставлено);
//ЭтаФорма.ОбновитьОтображениеДанных(Элементы.СписокРеализацииТоваровУслуг);
Элементы.СписокРеализацииТоваровУслуг.Обновить();
КонецПроцедуры

Как это в форме:

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.