helpf.pro
Регистрация
 0 
Распечатать

Как установить отбор в справочнике «без помеченных на удаление» программным путем?

Когда справочник наполняется помеченными на удаление объектами, они начинают мешать пользователям выбирать значение справочника. Бывает, что долго не представляется возможным удалить помеченные на удаление элементы. Чтобы пользователям они не мешали, можно программным путем отключить их видимость при открытии формы выбора (или формы списка) справочника с помощью предустановки отбора.
Делается это примерно таким способом. В диалоговой форме справочника назначается процедура «При открытии». И в модуле формы пишется примерно такой код:
Код 1C v 8.х
 Процедура ПриОткрытии()

// чтобы для выбора справочник открывался в неиерархическом виде (чтобы не нужно было каждый раз "раскрывать" папки в поисках нужного элемента)
ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Ложь;

// можно установить ограничение - для определенной роли
//Если НЕ РольДоступна("усРазработчик") Тогда

// установка собственно ограничения видимости помеченных на удаление элементов:
ЭлементОтбора = СправочникСписок.Отбор.Найти("ПометкаУдаления");
Если ЭлементОтбора = Неопределено Тогда
ЭлементОтбора = СправочникСписок.Отбор.Добавить("ПометкаУдаления");
КонецЕсли;
ЭлементОтбора.Установить(Ложь);
// чтобы можно было открыть отбор и вручную сбросить установленные выше флаг отбора:
ЭлементыФормы.СправочникСписок.НастройкаОтбора.ПометкаУдаления.Доступность = Истина;

// чтобы папки не отображались:
ЭлементОтбора = СправочникСписок.Отбор.Найти("ЭтоГруппа");
Если ЭлементОтбора = Неопределено Тогда
ЭлементОтбора = СправочникСписок.Отбор.Добавить("ЭтоГруппа");
КонецЕсли;
ЭлементОтбора.Установить(Ложь);
// чтобы можно было открыть отбор и вручную сбросить установленные выше флаг отбора:
ЭлементыФормы.СправочникСписок.НастройкаОтбора.ЭтоГруппа.Доступность = Истина;

//КонецЕсли;

КонецПроцедуры

Источник
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8107
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.