helpf.pro
Регистрация
 +4 
Распечатать

Создание и запись нового элемента справочника

Код 1C v 8.2 УП
 &НаКлиенте
Процедура ПоКнопкеНовыйКонтрагент(Команда)
// Вставить содержимое обработчика.
Перем НовыйКонтрагент;

НовыйКонтрагент = Новый Структура("Наименование, ПолноеНаименование, ИНН");
НовыйКонтрагент.Наименование = "РиК ООО";
НовыйКонтрагент.ПолноеНаименование = "ООО Рога и копыта";
НовыйКонтрагент.ИНН = "123456789012";


Если СоздатьНовогоКонтрагента(НовыйКонтрагент) = 0 Тогда
Сообщить("Не удалось создать нового контрагента");
КонецЕсли;

КонецПроцедуры


&НаСервере
Функция СоздатьНовогоКонтрагента(СтруктураСправочника)

Перем НовыйКонтрагент,СпрПользователи;

СпрКонтрагенты = Справочники.Контрагенты;
НовыйКонтрагент = СпрКонтрагенты.СоздатьЭлемент();
НовыйКонтрагент.Наименование = СтруктураСправочника.Наименование;
НовыйКонтрагент.ПолноеНаименование = СтруктураСправочника.ПолноеНаименование;
НовыйКонтрагент.ИНН = СтруктураСправочника.ИНН;
Попытка
НовыйКонтрагент.Записать();
Возврат 1;
Исключение
Возврат 0;
КонецПопытки;

КонецФункции



Код 1C v 8.х
 //Пример 1
НовыйЭлемент = Справочники.Контрагенты.СоздатьЭлемент();
НовыйЭлемент.Наименование = "ООО Березка";
// Установить другие реквизиты.
НовыйЭлемент.Записать();

НовыйЭлемент = Справочники.Банки.СоздатьЭлемент();
// Получить ссылку на группу, в которой будет находиться новый элемент.
Родитель = Справочники.Банки.НайтиПоКоду("000000001");
НовыйЭлемент.Наименование = "ВТБ";
НовыйЭлемент.Код = "000000011";
НовыйЭлемент.Родитель = Родитель;

// Установить другие реквизиты.
НовыйЭлемент.Записать();

//Пример 2
СпрСотр = Справочники.Сотрудники;
//или так:
//СпрСотр = Справочники["Сотрудники"]
НовЭл = СпрСотр.СоздатьЭлемент();
НовЭл.Наименование = "Иванов Иван Иванович";
НовЭл.Оклад = 100;
НовЭл.Записать();


Код 1C v 7.x
  //Пример 1
//создаваться будет прямо в корне справочника
спр = создатьОбъект("Справочник.Контрагенты");
спр.Новый();
спр.Наименование = "ООО Березка";
спр.УстановитьНовыйКод();
// итак далее
//спр.Реквизит1="......"
//спр.Реквизит2="......"
спр.Записать();

//Пример 2
СпрСотр = СоздатьОбъект("Справочник.Сотрудники");
СпрСотр.Новый();
СпрСотр.Наименование = "Иванов Иван Иванович";
СпрСотр.Оклад = 100;
СпрСотр.Записать();
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 40569
 +4 
Распечатать
Возможно, вас также заинтересует
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Был ли изменен элемент справочника? 0
// Модифицированность() - Определяет, был ли изменен объект после считывания из базы данных. // НО Метод не позволяет определить, был ли изменен объект другими пользователями. Если Модифицированность() тогда ...
Быстрый отбор в справочнике по первой букве 0
В статье описан способ быстрой организации отбора в списке справочника по первой букве наименования. Механизм легко дотачивается под собственные нужды. https://helpf.pro/uploads/img/_1-T4ZDj6uNPX.png // ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ ...
Ввод дополнительного ежегодного отпуска 0
Вид расчета, используемый для начисления оплаты дополнительного ежегодного отпуска , описывается в плане видов расчета Основные начисления организаций . Новый вид расчета удобнее создать копированием...
Посмотреть все результаты поиска похожих
Комментарии
ivnik
16.01.2013 18:53Комментарий: 1
ivnik
Код 1C v 8.2 УП
    
Спасибо!!!!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.