helpf.pro
Регистрация
 +1 
Распечатать

Удаление пустых колонок в таблице значений

Код 1C v 8.х
 Процедура УдалитьПустыеКолонкиТЗ(ТЗ)
МассивВозможноПустыхКолонок=Новый Массив;
Для Каждого ТекКолонка Из ТЗ.Колонки Цикл
МассивВозможноПустыхКолонок.Добавить(ТекКолонка.Имя);
КонецЦикла;
Для Каждого СтрТЗ из ТЗ Цикл
КолВоВозможноПустыхКолонок=МассивВозможноПустыхКолонок.Количество();
Для К=1 по КолВоВозможноПустыхКолонок Цикл
Если ЗначениеЗаполнено(СтрТЗ[МассивВозможноПустыхКолонок[КолВоВозможноПустыхКолонок-К]]) Тогда
МассивВозможноПустыхКолонок.Удалить(КолВоВозможноПустыхКолонок-К);
КонецЕсли;
КонецЦикла;
КонецЦикла;
КолВоВозможноПустыхКолонок=МассивВозможноПустыхКолонок.Количество();
Для К=0 по КолВоВозможноПустыхКолонок-1 Цикл
ТЗ.Колонки.Удалить(МассивВозможноПустыхКолонок[К]);
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7794
 +1 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.