helpf.pro
Регистрация
 +12 
Распечатать

Удаление строк Таблицы Значений

Код 1C v 8.х
    
// 1. Удаление строк согласно условию
НулевыеСтроки = ТаблицаПослеПодмен.НайтиСтроки(Новый Структура("Сумма",0));
Для каждого СтрокаТаблицы Из НулевыеСтроки Цикл
ТаблицаПослеПодмен.Удалить(СтрокаТаблицы)
КонецЦикла;

// Нужно оставить строки только соответствующие условию,а остальные удалить то:
ПараметрыОтбора = Новый Структура("Цена",15000);
ТЗНов = ТЗ.Скопировать(ПараметрыОтбора);
// в результате в ТЗнов будут только строки из ТЗ, в которых значение поля Цена = 15000

// 2. Удаление определенной строки, например УдаляемаяСтрока = 5;
ТаблицаЗначений.Удалить(УдаляемаяСтрока);

// 3. Удаление первой строки
ТаблицаЗначений.Удалить(0);

// 4. Удаление определенной колонки, например УдаляемаяКолонка = 3;
ТаблицаЗначений.Колонки.Удалить(УдаляемаяКолонка);

// 5. Удалить первую колонку
ТаблицаЗначений.Колонки.Удалить(0);

// 6. Удаление строк перебором, проверяя условие
СтаршийИндексКолонок = ТаблицаЗначений.Колонки.Количество() - 1;
Индекс = ТаблицаЗначений.Количество() - 1;
Пока Индекс > = 0 Цикл
Для Сч = 0 По СтаршийИндексКолонок Цикл
Если ТипЗнч(ТаблицаЗначений[Индекс][Сч]) = Тип("Число") Тогда
ТаблицаЗначений.Удалить(Индекс);
Прервать;
КонецЕсли;
КонецЦикла;
Индекс = Индекс - 1;
КонецЦикла;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 51632
 +12 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 10
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1Cv8.1CD - Файл данных достиг максимального размера! 4
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 4
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Посмотреть все результаты поиска похожих
Комментарии
Alex777222
12.11.2015 11:56Комментарий: 1
Alex777222

А еще можно так

Запрос = Новый Запрос;

Запрос.УстановитьПараметр("Период",Период);

Запрос.УстановитьПараметр("П",П);

Запрос.УстановитьПараметр("О",О);

Запрос.УстановитьПараметр("Н",Н);

Запрос.УстановитьПараметр("С",С);

Запрос.УстановитьПараметр("Таблица", Таблица);//Таблица - обрабатываемая таблица значений

Запрос.Текст =

"ВЫБРАТЬ

|Таблица.Период,

|Таблица.П,

|Таблица.О,

|Таблица.Н,

|Таблица.С

|ПОМЕСТИТЬ вт

|ИЗ

|&Таблица КАК Таблица

|ГДЕ

|Таблица.Период <>Период // нужные условия выборки по нескольким полям таблицы значений

|И Таблица.П <>П

|И Таблица.О <>О

|И Таблица.Н <>Н

|И Таблица.С <>С

|;

|

|////////////////////////////////////////////////////////////////////////////////

|ВЫБРАТЬ

|вт.Период,

|вт.П,

|вт.О,

|вт.Н,

|вт.С

|ИЗ

|вт КАК вт";

Таблица = Запрос.Выполнить().Выгрузить();// замещаем переменную

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.