helpf.pro
Регистрация
 0 
Распечатать

Определение пола по имени

Функция проверяет уже существующих в базе данных людей на наличие требуемого имени.
Во время поиска следует учитывать следующие ситуации:

1) Вместо имени записаны инициалы
2) Существуют имена, которые могут быть как мужскими, так и женскими (например, Саша)

На второй пункт можно возразить: следует писать полное паспортное имя, а не уменьшительное. На самом деле это не всегда удобно, особенно во время большого потока людей или же, например, при работе с иностранными именами.

Код 1C v 8.х
 Функция ОпределитьПол(Имя) Экспорт

Если СтрДлина(Имя) > 1 Тогда
Запрос = Новый Запрос("
|ВЫБРАТЬ
| П.Пол КАК Пол
|ИЗ
| Справочник.Пациенты КАК П
|ГДЕ
| ВЫРАЗИТЬ(П.Имя КАК СТРОКА(100)) = ВЫРАЗИТЬ(&Имя КАК СТРОКА(100))");
Запрос.УстановитьПараметр("Имя",Имя);
Результат = Запрос.Выполнить().Выгрузить();

М = 0;
Ж = 0;
Для Каждого Строка Из Результат Цикл
Если Строка.Пол = Перечисления.Пол.Мужской Тогда
М = 1;
КонецЕсли;
Если Строка.Пол = Перечисления.Пол.Женский Тогда
Ж = 1;
КонецЕсли;
КонецЦикла;

Если (М = 1) И (Ж = 0) Тогда
Возврат Перечисления.Пол.Мужской;
КонецЕсли;
Если (М = 0) И (Ж = 1) Тогда
Возврат Перечисления.Пол.Женский;
КонецЕсли;
КонецЕсли;

КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9428
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Комментарии
Voittamaton
19.08.2011 07:47Комментарий: 3
Voittamaton
E_Migachev, умно :-)
E_Migachev
16.08.2011 09:51Комментарий: 2
E_Migachev
8SiriuS8, причем, сюдя по коду - Пол - считывается из справочника Пациенты - по сути это пример поиска людей по введенному имени
А вот пример Функция определяет пол работника по его отчеству - всего в 8 строк )
8SiriuS8
16.08.2011 02:01Комментарий: 1
8SiriuS8
А чё такой код громоздкий. Слабо сократить до 15 строк *02
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.