helpf.pro
Регистрация
 +1 
Распечатать

Табличное поле ~ Колонка с Флажком для пометки необходимых документов

Вопрос:
Есть ТЗ с типом Значения ДокументСписок.ПоступлениеТоваровУслуг. Мне необходимо добавить еще одну колонку, в котором пользователь сможет отмечать необходимые документы для дальнейшей обработки(флажок, поставил/снял галочку).

Ответ:
Код 1C v 8.х
 Перем СписокДокументовДляОбработки;

Процедура ТабличноеПоле1ПриПолученииДанных(Элемент, ОформленияСтрок)

Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
ОформлениеСтроки.Ячейки.Флажок1.УстановитьФлажок(СписокДокументовДляОбработки.Получить(ОформлениеСтроки.ДанныеСтроки.Ссылка) <> Неопределено);
КонецЦикла;

КонецПроцедуры

Процедура ТабличноеПоле1ПередНачаломИзменения(Элемент, Отказ)

Если ЭлементыФормы.ТабличноеПоле1.ТекущаяКолонка.Имя = "Флажок1" Тогда
Отказ = Истина;
Ссылка = ЭлементыФормы.ТабличноеПоле1.ТекущиеДанные.Ссылка;
Если СписокДокументовДляОбработки.Получить(Ссылка) = Неопределено Тогда
СписокДокументовДляОбработки.Вставить(Ссылка, Ссылка);
Иначе
СписокДокументовДляОбработки.Удалить(Ссылка);
КонецЕсли;
КонецЕсли;

КонецПроцедуры

СписокДокументовДляОбработки = Новый Соответствие;

Колонка = ЭлементыФормы.ТабличноеПоле1.Колонки.Вставить(0, "Флажок1");
Колонка.Имя = "Флажок1";
Колонка.Ширина = 3;
Колонка.Данные = "";
Колонка.ДанныеФлажка = "ПометкаУдаления";
Колонка.ИзменятьПозицию = Ложь;
Колонка.ИзменениеРазмера = ИзменениеРазмераКолонки.НеИзменять;
Колонка.ИзменятьВидимость = Ложь;
Колонка.ИзменятьНастройку = Ложь;
Колонка.РежимРедактирования = РежимРедактированияКолонки.Непосредственно;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8572
 +1 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Где скачать классификатор ФИАС (вместо КЛАДР) для загрузки в 1С и как установить ФИАС? 2
Думаю, уже многие слышали что KLADR заменен на ФИАС (Федеральная информационная адресная система) Единой информацией из ФИАС будут обязаны пользоваться все ведомства – ГИБДД, Росреестр, ЗАГС, ФМС России и др, в...
Запись во внешний источник данных из 1С 8.2 3
Начиная с платформы 8.2.14 в 1С появилась коллекция " Внешние источники данных ". Использование объектов этой коллекции позволяет работать с внешними данными через ODBC. Стандартные механизмы платформы позволяют...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.