helpf.pro
Регистрация
 -1 
Распечатать

Как определить в каком режиме запущена программа(тонкий, толстый, web-клиент)?

Код 1C v 8.2 УП
 &НаСервереБезКонтекста
Функция ПолучитьТипКлиента()
Соединения=ПолучитьСоединенияИнформационнойБазы();
ТекущееСоединение=Соединения.Получить(НомерСоединенияИнформационнойБазы()-1);
Если ТекущееСоединение=Неопределено Тогда
Возврат "";
КонецЕсли;
Возврат (ПредставлениеПриложения(ТекущееСоединение.ИмяПриложения));
КонецФункции

&НаКлиенте
Процедура Тест(Команда)
Сообщить(ПолучитьТипКлиента());
КонецПроцедуры

еще вариант:
Код 1C v 8.2 УП
 Функция ПолучитьТекущуюСредуВыполнения() Экспорт

#Если ТолстыйКлиентОбычноеПриложение ИЛИ ТолстыйКлиентУправляемоеПриложение Тогда

Возврат "Толстый клиент";
#ИначеЕсли Сервер Тогда

Возврат "Сервер";
#ИначеЕсли ВнешнееСоединение Тогда

Возврат "Внешнее соединение";
#ИначеЕсли ТонкийКлиент Тогда

Возврат "Тонкий клиент";
#ИначеЕсли ВебКлиент Тогда

Возврат "Веб-клиент";
#Иначе

Возврат "Ошибка определения среды выполнения";
#КонецЕсли

КонецФункции
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 9323
 -1 
Распечатать
Возможно, вас также заинтересует
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
HTML5 Canvas в 1С 8.3 или Google нам поможет 0
Добрался я для написания маленьких тестов для 1С в плане web графики. Версии 1С 8.2.61 и 8.3.3.641. Зайдем на http://www.w3schools.com/html/html5_canvas.asp и перенесем примеры в обработку 1С. Скачать обработку: Результаты не радуют. 1С в Intern
V82.COMConnector.1: Не найдена лицензия COM-соединением 1
При подключении из одной базы к другой через COM внезапно стала появляться следующая ошибка: «V82.COMConnector.1: Не найдена лицензия COM-соединением», хотя никаких изменений на серверах не делалось. Релиз платформы был 8.2.13....
Веб браузер в 1С используя поле HTML документа 0
Настраивал клиенту CRM, он захотел - чтобы панель управления сайтом была в 1С. Хочет - делаем: Обработка Веб браузер проста, состоит из поля HTML документа и 20 строчек кода: Код команд: НаКлиенте Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.