helpf.pro
Регистрация
 0 
Распечатать

Функция описывает период, определяемый датой и периодичностью

Код 1C v 8.х
 
// Функция описывает период, определяемый датой и периодичностью
Функция ПолучитьПериодСтрокой(ДатаВПериоде, Периодичность) Экспорт
Если Периодичность = "Год" Тогда
ФорматДаты = "ДФ='гггг ""г.""'";
ИначеЕсли Периодичность = "Квартал" Тогда
ФорматДаты = "ДФ='к"" квартал"" гггг ""г.""'";
ИначеЕсли Периодичность = "Месяц" Тогда
ФорматДаты = "ДФ='ММММ гггг ""г.""'";
ИначеЕсли Периодичность = "Неделя" Тогда
ФорматДаты = "ДФ='""Неделя (""дд.ММ.гггг'";
ИначеЕсли Периодичность = "День" Тогда
ФорматДаты = "ДФ='дд.ММ.гггг ""г.""'";
Иначе
ФорматДаты = "";
КонецЕсли;
СтрокаПериод = "" + Формат(ДатаВПериоде, ФорматДаты);
Если Периодичность = "Неделя" И ТипЗнч(ДатаВПериоде) = Тип("Дата") Тогда
СтрокаПериод = "" + НеделяГода(ДатаВПериоде) + "-ая " + СтрокаПериод + Формат(КонецНедели(ДатаВПериоде), "ДФ='"" - ""дд.ММ.гггг)'");
КонецЕсли;
Возврат СтрокаПериод;
КонецФункции

//Обращение и результат
Сообщить(ПолучитьПериодСтрокой(Дата(2009,03,09),"Квартал")); // 1 квартал 2009 г.
Сообщить(ПолучитьПериодСтрокой(Дата(2009,03,09),"День")); // 09.03.2009 г..
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6060
 0 
Распечатать
Возможно, вас также заинтересует
Выбрать все движения регистра с остатками 0
Метод ВыбратьДвиженияСОстатками инициирует выбор всех движении регистра в указанном интервале дат. До вызова данной процедуры может быть установлен фильтр (см. УстановитьФильтр), ограничивающий выборку значений из...
Дополнение результата запроса Датами в Установленном ПЕРИОДЕ 0
Иногда возникает необходимость вывести в отчет информацию таким образом, чтобы некоторые итоговые значения были рассчитаны на каждую дату в заданном интервале с указанной периодичностью. Например, требуется...
Задания по расписанию, РегламентноеЗадание 1
Применяется если требуется выполнять какое-то действие с определенной периодичностью. Например, резервное копирование БД или обновление индексов полнотекстового поиска. Рассмотрим вариант обновления индексов. ...
Как определяется период регистрации регистра расчета? 0
Есть три варианта ответов: 1. автоматически в момент ввода информации в регистр из документа-регистратора 2. программно в момент ввода информации в регистр из документа-регистратора 3. вручную после ввода записи в...
Как удалить должность из штатного расписания ЗУП 2.5 2
Для Удаления должности из штатного расписания вводится новая строка на эту должность в штатное расписание с нужной датой(с которой должность убирается) и количеством ставок = 0 .
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.