helpf.pro
Регистрация
 +3 
Распечатать

Преобразование даты 1С в unixtime (Unix Time Stamp)

Как известно, unixtime содержит количество секунд, прошедших с 1 января 1970 года. Поэтому, для преобразования даты 1С в дату unixtime нам всего то нужно от нашей даты отнять дату 01.01.1970 и перевести получившееся значения в удобоваримый формат.
Код 1C v 8.х
 unixtime = Формат(ТекущаяДата() - дата(1970,1,1,1,0,0), "ЧГ=0");   

Соответственно, для обратного преобразования нам надо дату unixtime прибавить к дате 01.01.1970:
Код 1C v 8.х
 Дата1С = дата(1970,1,1,1,0,0) + unixtime;   


Готовые функции:
Код 1C v 8.х
 // Возвращает время в формате UNIX 
Функция ПолучитьUnixTS(ПараметрДата)
Возврат УниверсальноеВремя(ПараметрДата) - '19700101';
КонецФункции


Код 1C v 8.х
 //время 1с 
Функция СконвертироватьВремяUnixTS(UnixTime)
Возврат МестноеВремя('19700101' + UnixTime);
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 10140
 +3 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
В учетной политике не указан вид тарифа страховых взносов. Как указать? 0
Создайте новую запись учетной политики с начала года - Например 01.01.2013 В учетной смотрите дату начала учетной политики. Поставьте дату начала года (например 01.01.13) закладка появиться должна. Проверьте Тариф страховых...
Ввести дату, ввод даты 1
ДатаНапоминания = РабочаяДата; Подсказка = "Введите дату и время"; ЧастьДаты = ЧастиДаты.ДатаВремя; Если ВвестиДату(ДатаНапоминания, Подсказка, ЧастьДаты) Тогда // обработка даты напоминания КонецЕсли Если...
Ввод договоров ГПХ в ЗУП (счет 76) 5
Часто меня спрашивают: Как правильно отразить договор ГПХ в ЗУП? Ниже небольшая, последовательная инструкция: Прием на работу Сведения о физическом лице, выполняющем работы по договору подряда, должны быть внесены...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.