helpf.pro
Регистрация
 +1 
Распечатать

Ввести перечисление, выбор перечисления

Код 1C v 8.х
 
// В 8-ой версии нет такой фунции, но можно сделать так:
ЗначПер=Перечисления.Важность.Средняя; //Установим перечисление предлагаемое выбрать по умолчанию
Если ВвестиЗначение(ЗначПер,"Выберите важность:") тогда
Сообщить(ЗначПер); //обработка выбора
КонецЕсли;


Код 1C v 7.x
 
Процедура УстПризнак1()
ВыбПризн = Перечисление.ТипСотрудника.Штатный;
Если ВвестиПеречисление(ВыбПризн, "Выберите тип") > 0 Тогда
Тип = ВыбПризн;
Иначе
Тип = Перечисление.ТипСотрудника.Штатный;
КонецЕсли;
КонецПроцедуры

Процедура УстПризнак2()
ВыбПризн = "ТипСотрудника";
Если ВвестиПеречисление(ВыбПризн, "Выберите тип") > 0 Тогда
Тип = ВыбПризн;
Иначе
Тип = Перечисление.ТипСотрудника.Штатный;
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 9825
 +1 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Авто добавление обработки в справочник Внешних обработок 0
Чтобы не изменять типовую конфигурацию приходится использовать типовой механизм внешних печатных форм и обработок. Данный код проверяет - добавлена ли открываемая обработка в конфигурацию, если нет - задает вопрос и...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.