helpf.pro
Регистрация
 0 
Распечатать

Функция сравнение значений перечислений на больше/меньше

Код 1C v 8.х
 
// сравнение значений перечислений на больше/меньше
// применяется для перечислений, для которых последовательность
// значений имеет определяющее значение
//
// Параметры:
// Значение1, Значение2 - сравниваемые значения перечислений
//
// Возвращаемое значение: число
// 1 - если Значение1 > Значение2
// -1 - если Значение1 < Значение2
// 0 - если Значение1 = Значение2
//
Функция СравнениеПеречислений(Значение1, Значение2) Экспорт
ИмяПеречисления = Метаданные.НайтиПоТипу(ТипЗнч(Значение1)).Имя;
Менеджер = Перечисления[ИмяПеречисления];
Если Менеджер.Индекс(Значение1) > Менеджер.Индекс(Значение2) Тогда
Возврат 1;
ИначеЕсли Менеджер.Индекс(Значение1) < Менеджер.Индекс(Значение2) Тогда
Возврат -1;
Иначе
Возврат 0;
КонецЕсли;

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 11698
 0 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 49
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Cклонения по падежам 6
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать инициализированный объект или
Автоматическое резервное копирование 1С:Предприятия в облако с помощью ПО Effector Saver 3
Всем известно, для большей гарантии восстановления важных данных, необходимо копировать архивы в несколько мест хранения. Отдельный диск может помочь в случае порчи основного, но в случае если устройство будет потеряно или украдено, он будет так же
Автоматическое резервное копирование 1С:Предприятия в облако с помощью ПО Effector Saver 0
Всем известно, для большей гарантии восстановления важных данных, необходимо копировать архивы в несколько мест хранения. Отдельный диск может помочь в случае порчи основного, но в случае если устройство будет потеряно или украдено, он будет так же
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.