helpf.pro
Регистрация
 0 
Распечатать

Удаление из строки всех нечисловых символов

Иногда необходимо избавиться от нечисловых символов в строке. Например если сканер штрихкода или ридер магнитных карт добавляют в считываемую строку свои служебные символы.

Вот нехитрая функция для решения этой задачи

Код 1C v 7.x
 
Функция УбратьНечисловые(Стр)
ОбрСтр = СокрЛП(Стр);
Результат = ОбрСтр;
Для н=1 по СтрДлина(ОбрСтр) Цикл
ТекСимвол = Сред(ОбрСтр,н,1);
Если Найти("0123456789",ТекСимвол) = 0 Тогда
Результат = СтрЗаменить(Результат,ТекСимвол,"");
КонецЕсли;
КонецЦикла;
Возврат Результат;
КонецФункции
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 8934
 0 
Распечатать
Возможно, вас также заинтересует
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Выгрузка / Загрузка данных посредством текстовых (TXT) файлов 2
Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста . Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент загружает файл...
Загрузка Dbf-файлов с длиной имени больше 8 символов 0
Во время написания обработки чтения dbf файла столкнулся с проблемой: длина имени файла больше 8-ми символов. Вот так решил проблему: Процедура ПрочитатьФайлНажатие(Элемент) //Получаем объект Файл НашФайл = Новый...
Загрузка данных из текстовых файлов с выборкой через ADO. 0
Часто бывает потребность загружать данные из текстовых форматов, причем информация для загрузки бьется на 2 и более файлов. Хорошо бы посредством SQL запроса выбирать данные из этих файлов и производить загрузку! Это...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.