helpf.pro
Регистрация
 0 
Распечатать

Как программно выполнить задачу БП?

Код 1C v 8.2 УП
 &НаСервере
Процедура ЗафиксироватьВыполнениеНаСервере()

ЗадачаОбъект = Задача.Ссылка.ПолучитьОбъект();

ЗадачаОбъект.ВыполнитьЗадачу();

КонецПроцедуры


Код 1C v 8.х
 ТекстВопроса = "Задача будет завершена. Продолжить?";
ОтветНаВопрос = Вопрос(ТекстВопроса,РежимДиалогаВопрос.ОКОтмена,,КодВозвратаДиалога.ОК);
Если ОтветНаВопрос = КодВозвратаДиалога.ОК Тогда
ВыполнитьЗадачуИнтерактивно();
ЗаписатьВФорме();

// условие для БП Поручение
Если ТипЗнч(БизнесПроцесс) = Тип("БизнесПроцессСсылка.CRM_Поручение")
И (ТочкаМаршрута.Имя = "Контроль")Тогда
БизнесПроцессЗадачи = ЗадачаОбъект.БизнесПроцесс.ПолучитьОбъект();
БизнесПроцессЗадачи.КачествоВыполнения = ЭлементыФормы.Оценка.Значение;
БизнесПроцессЗадачи.Записать();
КонецЕсли;
Закрыть();
КонецЕсли;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 17575
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 11
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который выпускает компания 1С . Что такое
Автоматическое резервное копирование 1С:Предприятия в облако с помощью ПО Effector Saver 3
Всем известно, для большей гарантии восстановления важных данных, необходимо копировать архивы в несколько мест хранения. Отдельный диск может помочь в случае порчи основного, но в случае если устройство будет потеряно или украдено, он будет так же
Автоматическое резервное копирование 1С:Предприятия в облако с помощью ПО Effector Saver 0
Всем известно, для большей гарантии восстановления важных данных, необходимо копировать архивы в несколько мест хранения. Отдельный диск может помочь в случае порчи основного, но в случае если устройство будет потеряно или украдено, он будет так же
Активация открытой книги Excel для корректировки 0
Нужно было получить для изменения уже открытую книгу Excel, а если она закрыта, то открыть и изменять. Ниже код, который данную задачу решает. Попытка Эксель = Неопределено; Книга = Неопределено; Лист = Неопределено; Состояние(" Выполняется
Ввести перечисление, выбор перечисления 2
// В 8-ой версии нет такой фунции, но можно сделать так: ЗначПер=Перечисления.Важность.Средняя; //Установим перечисление предлагаемое выбрать по умолчанию Если ВвестиЗначение(ЗначПер,"Выберите важность:") тогда Сообщить(ЗначПер); //обработка в
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.