helpf.pro
Регистрация
 0 
Распечатать

Внешняя печатная форма, дополнительные параметры для печати

Внешняя обработка (Печатная форма), содержащая: Необязательный реквизит «ДополнительныеПараметры» произвольного типа, которому будут передаваться дополнительные параметры примитивного типа в виде структуры.
title
Аналогично можно передать параметр во внешнюю печатную форму через реквизит «ДополнительныеПараметры».
В модуле обработки для использования этих параметров используем следующий код вида:
Код 1C v 8.х
 Если ТипЗнч(ДополнительныеПараметры) = Тип("Структура") Тогда
Если ДополнительныеПараметры.Свойство("КодФилиала") Тогда
КодФилиала = ДополнительныеПараметры.КодФилиала;
Иначе
КодФилиала="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("КодОрганизации") Тогда
КодОрганизации = ДополнительныеПараметры.КодОрганизации;
Иначе
КодОрганизации="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("ОтделениеБанка") Тогда
ОтделениеБанка = ДополнительныеПараметры.ОтделениеБанка;
Иначе
ОтделениеБанка="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("НомерДоговора") Тогда
НомерДоговора = ДополнительныеПараметры.НомерДоговора;
Иначе
НомерДоговора="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("ДатаДоговора") Тогда
ДатаДоговора = ДополнительныеПараметры.ДатаДоговора;
Иначе
ДатаДоговора="";
КонецЕсли;
КонецЕсли;


Настроим передачу параметров внешней печатной форме
Для этого создаем новый элемент справочника «Внешние обработки» и заполняем его, как показано на рисунке ниже
В табличной части открываем Параметры обработки и вводим значения параметров
title
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 14635
 0 
Распечатать
Возможно, вас также заинтересует
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать...
Авто добавление обработки в справочник Внешних обработок 0
Чтобы не изменять типовую конфигурацию приходится использовать типовой механизм внешних печатных форм и обработок. Данный код проверяет - добавлена ли открываемая обработка в конфигурацию, если нет - задает вопрос и...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.